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Mission Statements 
 
The mission of the Department of the Interior is to protect and 
provide access to our Nation’s natural and cultural heritage and 
honor our trust responsibilities to Indian Tribes and our 
commitments to island communities. 
 
 
 
The mission of the Bureau of Reclamation is to manage, develop, 
and protect water and related resources in an environmentally and 
economically sound manner in the interest of the American public. 
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1 Introduction 
ArcTim is a GIS based interface for TimML, a multi-aquifer analytic element 
model (AEM).  AEMs have been used by many different entities to evaluate 
groundwater systems and groundwater/surface water interactions.  AEMs solve 
the equation for groundwater flow everywhere, unlike finite element or finite 
difference models that solve the equation at the center of a discrete region.  This 
makes them especially useful for investigating situations where hydrologic 
features are very close to one another. 
 
Analytic element models can require large amounts of data, since a solution will 
be given at the resolution of the input data.  Introducing GIS into the development 
of an AEM can greatly increase the speed at which a user can develop and model 
and produce a solution making AEMs very efficient tools for solving groundwater 
related problems. 
 
Other single aquifer AEMs have been used in the past in conjunction with GIS to 
develop groundwater surface water interaction models (USBR, 2008).  ArcTim 
combines a multi-aquifer AEM with GIS to investigate problems that include 
interactions between aquifers. 
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2 Installation 

2.1 Software Requirements 

ArcTim requires the following software to work properly.   
• ArcMap 9.3 with service pack 1  
• Python 2.6.X  
• TimML 3.4  

 

2.2 Installing ArcTim 

TimML should be installed on your computer by following the instructions 
provided by the developer, Mark Bakker.  They are provided here for 
convenience: 
 
Although it is possible to download all required Python packages separately, it is 
much easier to install one of the Python installers that comes with a large 
selection of popular packages. Two of the best options on Windows are 
PythonXY and the Enthought Python distribution. PythonXY is free for 
everybody, the Enthought distribution is free for use in Academia and available 
for a small fee to others. The installation is straightforward and consists of the 
following steps: 

• When you use want to use PythonXY, download the PythonXY installer 
for Python 2.6 from http: //www.pythonxy.com/download.php (Version on 
March 10, 2010 is 2.6.2.0). Once downloaded, install PythonXY. 

• When you want to use the Enthought distribution, download the 
Enthought installer for Python 2.6 from http://www.enthought.com 
(Version on March 10, 2010 is EPD6.1 ). Once downloaded, install the 
Enthought distribution. 

• Download the Shapely library for Python 2.6 from 
http://pypi.python.org/pypi/Shapely/1.0.14 (The version on March 10, 
2010 is 1.0.14, so download the file Shapely-1.0.14.win32.py26.exe). 
Install Shapely. 

• Download and install the latest version of TimML from 
http://code.google.com/p/timml/ (The version on March 24, 2010 is 
TimML-3.4.0.py26.win32.exe). 

(Bakker, 2010) 
 

http://pypi.python.org/pypi/Shapely/1.0.14
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ArcTim can then be installed by clicking on the provided ArcTimInstaller.msi and 
following the instructions.  Once it is installed, the toolbar can be activated in 
ArcMap by clicking on View>Toolbars>ArcTim 2.0. 
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3 ArcTim Toolbar 
The ArcTim toolbar provides a number of tools that can be used to develop, run 
and view output from a TimML model.  Figure 3-1 shows the toolbar that is 
available in ArcMap and that can be installed following the instructions in section 
4.0 of this report. 
 

 
Figure 3-1: ArcTim toolbar available in ArcMap. 
 

3.1 Model Menu 

The first menu item, called the Model dropdown menu, lists some of the basic 
functions of the ArcTim toolbar (Figure 3-2).  As in many programs, there is a 
save function that will allow the user to save the settings that are set in the Model 
Settings and Output Setting windows.  Saved model files are in XML format and 
the save function automatically sets the saved model file as an XML file.  In 
addition, there is an open function that will open previously saved model and 
output settings. 
 

 
Figure 3-2: Model Dropdown menu 
 
The Model Settings window is where the user sets the basic information about the 
TimML model.  Figure 3-3 shows the Aquifer Properties tab of the Model Settings 
window.  The user first sets the number of aquifer layers by clicking the Change 
Number of Layers button.  Once the number of layers is defined, the user can 
click on the Layer dropdown box and select the layer that will correspond to the 
properties displayed in the boxes.  The properties can be changed simply by 
typing in the boxes.  If the user has saved a model file, the properties will be 
updated in the saved file when the user clicks OK on the Model Settings window.  
Otherwise, the parameters will be saved in a temporary file until the user creates a 
saved model file or when ArcMap is closed.  More information about the required 
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properties for a TimML file can be found in the TimML User’s Manual (Bakker, 
2008). 
 
 
 

 
Figure 3-3: Model Settings window where user sets basic model input. 
 
The shapefiles that will be used in the TimML model can be indicated in the 
Shapefiles tab of the Model Settings window (Figure 3-4).  Shapefiles that are 
listed in the tree in the open ArcMap document will populate the dropdown 
menus under Shapefile Name.  All shapefiles that will be used in the current 
model need to be listed in the tree.  The dropdown boxes under Tim Feature Type 
will be populated with all of the available TimML hydrologic feature types.  The 
user should select the shapefile name and the time file type that corresponds to the 
shapefile.  There can be more than one shapefile for a given feature type, but not 
more than one feature type for a shapefile.  If the shapefile is to be used in the 
current model, the Active box should be checked. 
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Figure 3-4: Shapefiles tab of the Model Settings window. 
 
Figure 3-5 shows the Output Settings window.  The user can set the extents to 
which the model develops a solution by either selecting Use Current Extents or 
Define Extents.  Use Current Extents will use the extents of the current map view 
and Define Extents allows the user to set the extents which can be useful if it is 
desired that the solution extents remain the same no matter how the user moves 
around within the map.  Also in this window, the resolution of the solution can be 
selected by selecting Use Pre-Defined resolution  and either low, medium or high, 
where the extents will be divided by either 10, 100 or 1000 units (the higher the 
resolution, the longer the output files will take to be created).  The user can also 
specify the number of cells by which to divide the extents by selecting Use 
Number of Cells and entering the number of cells in each direction.  Output will 
always be produced for each aquifer layer. 
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Figure 3-5: Output Settings window. 
 
 

3.2 Shapefile Tools Menu 

Each hydrologic feature in a TimML model requires specific inputs (Table 3-1).  
The names listed in the Attribute Name column are required attribute names for 
the TimML interpreter and it is these attribute names that are used in the Convert 
Existing Shapefile and Create New Shapefile tools. 
 
 
Table 3-1: TimML hydrologic features and input requirements. 

TimML feature type  Attribute Name  Description of Attribute  
Constant  Head  Head at the reference point  
   Layer*  Layer in which the 

reference point is located  
   Name  Name of the reference point  
Well  Discharge  Discharge [L3/T] of the 

well  
   Radius  Radius of the well  
   Layer*  Layer(s) in which the well 

is located  
   Name  Name of the well  
FlowLineSink  Sigma  Strength (or flux per unit 

length) of the linesink 
[L2/T]  

   Layer*  Layer(s) in which the 
linesink is located  

   Name  Name of the linesink  
HeadLineSink  Head  Head in the linesink at the 

center of the linesink  
   Layer*  Layer(s) in which the 

linesink is located  
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   Name  Name of the linesink  
ResLineSink  Head  Head in the linesink at the 

center of the linesink  
   Resistance  Resistance of the linesink to 

inflow and outflow  
   Width  With of the linesink  
   Layer*  Layer(s) in which the 

linesink is located  
   Name  Name of the linesink  
   BotElev  Leaky resistance layer at 

the bottom of the linesink  
CircAreaSink Radius Radius of the circular 

infiltration zone 
 Infil Infiltration 
 Label Name of the CircAreaSink 
 Layer Layer in which the 

CircAreaSink is located. 
 
The Shapefile Tools Menu options allow the user to easily develop formatted 
shapefiles that contain the required input data for TimML.  The first option, 
Convert Existing Shapefile, allows the user to convert an existing shapefile of 
hydrologic features to a format that can be interpreted by the TimML model.  The 
second option, Create New Shapefile, allows the user to create an empty shapefile 
with the attributes that will be necessary for a particular feature in TimML, as 
shown in Table 3-1. 
 

3.3 Grid Tools 

The grid tools were developed to facilitate the use of MODFLOW solutions as 
boundary conditions for TimML models.  This feature is based on the theory that 
some hydrogeologic questions are better answered by analytic means versus using 
a grid based solution.  Examples of such questions are how do nearby wells 
impact each other when pumping or how does a pumping well impact a nearby 
stream?  This feature allows the user to extract output from a MODFLOW grid 
solution and use it as boundary conditions for a TimML model simulation. 
 
There are three tools, Create Grid.shp from MODFLOW, Add Head from 
MODFLOW, and MODFLOW to Tim.  Create Grid.shp from MODFLOW utilizes 
the discretization file from MODFLOW to generate a grid with the number of cell 
and cell sizes that are used in the MODFLOW calculation.  The MODFLOW 
discretization file does not contain a geographic projection, so the user has the 
option to translate and rotate the grid so that it lines up with other projected map 
features.  The Add Head from MODFLOW tool adds the output from the 
MODFLOW calculation to the grid developed by the Create Grid.shp from 
MODFLOW tool.  The MODFLOW to Tim tool selects output from the 
MODFLOW grid and populates boundary line segments that overlap the grid. 
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3.4 Run TimML 

The Run TimML button  (Figure 3-6) creates a TimML input file from the data set 
up in the Model Settings Window, runs the TimML model and then imports the 
solution based on the resolution defined in the Output Settings Window.   
 

 
Figure 3-6: The Run TimML button circled on the ArcTim 2.0 toolbar. 

3.5 ArcTim Troubleshooting 

Since ArcTim resides in ArcMap, there are a couple of ArcMap related issues that 
can come up if the following criteria are not followed: 

1. All of the shapefiles need to be in the same directory. 
2. No spaces are allowed in the file path.  
3. All of the shapefiles need to be in the same projection and spatial 

reference. 
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4 Example 1: Develop and run a simple 
TimML model using ArcTim 

This example uses Example 1 that was developed for TimML.  It will show the 
user the necessary formats for the shapefiles, the process used to run a TimML 
model and methods for viewing the model output. 
 
Example 1 defines a model with three layers separated by two leaky layers.  This 
is a slightly different way of defining an aquifer than would be done using 
MODFLOW and more details about the way that TimML defines aquifer layers 
can be found in the TimML manual (Bakker, 2010).  The aquifer for Example 1 is 
defined by the following properties (Table 4-1): 
 
Table 4-1: Example 1 aquifer properties (adapted from Bakker 2010). 
 Hydraulic 

Conductivity 
Bottom 
Elevation 

Top 
Elevation 

Resistance Porosity Vertical 
Porosity 

 K (m/d) Bottom 
(m) 

Top (m) C (days) N (-) Nv (-) 

Aquifer 1 2 140 165  0.3  
Leaky 
Layer 2 

 120 140 2000  0.2 

Aquifer 2 6 80 120  0.25  
Leaky 
Layer 3 

 60 80 20000  0.25 

Aquifer 3 4 0 60  0.3  
 
 
Step 1: Open the Example1 map document and view the setup of the 
shapefiles.  Open the map document C:/ArcTim/Example1Files/Example1.mxd.  
Note the four shapefiles in the tree, Constant.shp, headLineSink2.shp, wells.shp 
and cricareaSink.shp.  Open the individual attribute tables and look at the format 
and verify that the names of the individual attributes correspond to the required 
attributes listed in Table 3-1.  This is the required format for ArcTim to work 
properly, so any new shapefiles added to a TimML model should follow this 
format (listed in Table 3-1). 
 
Step 2:  Input the model properties.  The model properties are set up slightly 
different than the properties that are defined in Table 4-1.  Only the properties of 
the aquifer layers themselves are included in the model setup, and the resistance 
and vertical porosity are assigned the layer that is above the leaky layer they are 
associated with.  Set up the model settings by opening the Model Setting Window 
in Model>Model Settings.  Table 4-1 lists the aquifer properties for Example 1.  
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Enter the properties in the Model Settings Window.  When the Model Properties 
Window is closed (by clicking OK), when asked for the model name, navigate to 
C:/ArcTim/Example1/Example1Files and save the model as Example1.xml. 
 
Table 4-2: Aquifer properties for Example 1 TimML model. 

Layer Top Bottom K Resistance Porosity PorosityV 
1 165 140 2 2000 0.3 0.2 
2 120 80 6 20000 0.25 0.25 
3 60 0 4  0.3  
 
Step 3:  View the parameters in the Output Settings Window.  Open the 
Output Settings Window.  In the Define Output Extents box, click the Define 
Extents button and verify that the values in the boxes match those in Table 4-3.  In 
the Output Resolution box, click the Use number of cells and verify that the 
number of cells in both boxes is 101. 
 
Table 4-3:  Output extents for Example 1. 
 X Y 
Min -4467.06623164764 24.7999999999992 
Max 25115.9675562806 29607.8337879282 
 
Step 4: Run TimML.  Click the Run TimML button.  This button will generate a 
TimML input file, run TimML and import a raster file of the solution for each 
aquifer layer.  Notice that the raster files are named with the first 6 characters of 
the model name followed by the layer number that the raster represents. 
 
Step 5: Use ArcGIS tools to explore the TimML output.  The raster output from 
the TimML model will be imported in the order it is created which results in the 
top most aquifer layer being imported first and therefore underneath the other 
layers.  Turn the raster layers on and off to view individual model layers.  The 
raster files can be colored using the properties menu for each of the individual 
raster layers.  Spatial Analyst can be used to create contours for each of the raster 
layers. 
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5 Example 2: Develop and run a TimML 
model with MODFLOW generated 
boundary conditions 

Example 2 will use the shapefile tools to develop a TimML model that will utilize 
output from a MODFLOW model as boundary conditions.   
 
Step 1: Convert headLinesink2.shp to a file with TimML compatible 
attributes.  Open the attribute table of headLineSink2.shp and note that the 
attribute names do not match those listed in Table 3-1.  Convert the shapefile to a 
TimML compatible file by clicking on Shapefile Tools>Convert Existing 
Shapefile which will bring up a menu. Select a working directory (the same 
directory that the other shapefiles are in), select the shapefile that will be 
converted and select the type of TimML feature that the shapefile represents as 
shown in Figure 5-1 and Figure 5-2.  The output will be a new shapefile called 
headLineSink2_Tim.shp.  All shapefiles resulting from this tool will end with 
_Tim.shp. 
 

 
Figure 5-1: Step one to convert the headLineSink2.shp to a TimML compatible file. 
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Figure 5-2: Step two to convert the headLineSink2.shp to a TimML compatible file. 
 
Step 2:  Use the Create New Shapefile tool to create a new TimML 
compatible shapefile.  Note that the current map document does not have the 
required constant.shp.  Create the constant.shp shapefile using the Create New 
Shapefile tool by clicking on Shapefile Tools>Create New Shapefile (Figure 5-3).  
Enter the working directory (again, the directory that all of the other shapefiles are 
in), select the Tim Feature Type (constant, in this case), and type in the new file 
name, without the .shp extension.  A shapefile called constant_Tim.shp will be 
created when OK is clicked. 
 

 
Figure 5-3: Create New Shapefile tool. 
 
Step 3: Edit the new constant_Tim.shp shapefile.  Open the attribute table of 
the newly created constant_Tim.shp.  Since this tool is designed to only format 
the shapefile so that it is compatible with TimML, only the required attributes 
were created, but the table was not populated with data.  It is assumed that the 
user will use the ArcMap editor function to create the shape and data to add the 
appropriate attributes.  Start the editor function by opening the editor toolbar, 
View>Toolbar>Editor then click Editor>Start Editing on the toolbar.  Click on the 
pencil icon to create a new feature, right click on the map and click on the 
Absolute X, Y… function.  Enter 20000 for both X and Y.  This will create a 
constant feature at 20000,20000.  Open the constant_Tim.shp attribute table and 
enter 175 under Head, “constant” under Name, and 1 under Layer1.  Save the 
edits by clicking on Editor>Stop Edits.   
 
 
Step 4:  Run TimML.  At this point, the same model has been created that was 
run in Example 1.  To be sure that all of the shapefiles were created properly, run 
the model by setting up the model attributes and run TimML.   
 
Step 5: Add the MODFLOW Grid and Output to the map document. 
 
Step 6: Extract boundary conditions from the MODFLOW grid. 
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Step 7: Run the new TimML model with MODFLOW derived boundaries. 
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