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Disclaimer 
SRH-Mesh and this manual were developed for Reclamation’s use. Reclamation 
does not guarantee the performance of the program, nor helps external users solve 
their problems. Reclamation assumes no responsibility for the correct use of SRH-
Mesh and makes no warranties concerning the accuracy, completeness, reliability, 
usability, or suitability for any particular purpose for using the software or the 
information contained in this manual.  
SRH-Mesh requires engineering expertise to be used correctly. Like other 
computer programs, SRH-Mesh is potentially fallible. All results obtained from 
using the program should be carefully examined by an experienced engineer to 
determine if they are reasonable and accurate. Reclamation will not be liable for 
any special, collateral, incidental, or consequential damages in connection with 
the use of the software. 
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1. Introduction 
1.1 SRH-Mesh Description 
SRH-Mesh (Sedimentation and River Hydraulics – Mesh) is a graphical tool for 
generating unstructured two-dimensional (2D) meshes and is used for 2D 
hydraulics and sediment transport numerical simulations. It may import 
Geographic Information System (GIS) images and feature shapefiles; edit 
geometry; create triangle, quadrilateral, or mixed meshes; and create boundary 
condition lines. These generated meshes may be used in models such as the SRH-
2D model which is the flow and mobile-bed sediment transport model developed 
at Reclamation. This manual describes the common functions in SRH-Mesh and 
provides step-by-step tutorials to create 2D meshes for river applications. 

1.2 SRH-Mesh Capabilities 
SRH-Mesh generates 2D meshes for numerical simulation in hydraulic 
engineering. Some of the model’s capabilities are to: 
 

• Import GIS geo-referenced images 
• Import GIS geo-referenced shapefiles 
• Draw, edit, and redistribute geometry lines as sides of meshes 
• Create triangles, quadrilateral, mixed, or Voronoi meshes 
• Combine meshes 
• Assign bed properties 
• Assign polylines for boundary conditions 
• Assign boundary conditions 
• Set model parameters 

1.3 Acquiring SRH-Mesh 
Requests may be sent directly to Reclamation’s Sedimentation and River 
Hydraulics Group (Attention: SRH Support, Sedimentation and River Hydraulics 
Group, P.O. Box 25007 (86-68540), Denver, Colorado, 80225-0007). 
SRH-Mesh is under continuous development and improvement.  

1.4. Installation 
Administrative rights are needed to install the program but are not required to run 
the program once installed. The program is designed to run on Window’s 
platforms. However, the program has only been tested on Windows 10. Once 
installed, the program SRH-Mesh should be available through the start, programs 
menu under the SRH folder.  



SRH-Mesh 1.0 User’s Manual  
Graphical Interface 
 

2 

2. Graphical Interface 
Presently, SRH-Mesh is a tool for generating triangle, quadrilateral, and mixed 
meshes along with the boundary condition lines (BC lines). It may be used by 
SRH-2D through the partial interface mode. The mesh generator, however, is 
under continuous development. In the future, SRH-Mesh will integrate with SRH-
2D together so that the graphical interface of SRH-Mesh may be used to generate 
the mesh, assign boundary conditions, assign SRH-2D model inputs, run SRH-2D 
directly, and visualize model results. 
SRH-Mesh interface window consists of six main regions as shown in Figure 2-1: 
Menu Bar, Table of Contents, Module Indicator, Tool Buttons, Status Line, and 
Workspace. This section describes the main functions of each region. Please use 
the tutorials in Section 5 to learn how these functions work. 
 

 
Figure 2-1. SRH-Mesh’s main window showing the six main regions: Menu Bar, Tool 
Buttons, Table of Contents, Workspace, Module Indicator, and Position Indicator. 

2.1. Menu Bar 
SRH-Mesh’s features are organized into the following menus (Error! Reference 
source not found.: 

 
Figure 2-2. SRH-Mesh’s menu bar  

• File: control reading and writing of project files, and exiting SRH-Mesh 

• View: control button sizes and shows coordinate projections 
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• Insert: insert text, shape, marker, north arrow, or scale bar 

• Image: control image input 

• GIS: control GIS shape files inputs and transfers GIS shape files into 
SRH-Mesh polylines 

• Geometry: add, edit, or remove geometry 

• Mesh: generate the mesh, assign the bed roughness, bed gradation zone, 
and initial boundary condition zone 

• Boundary Line: add or delete boundary condition line 

• Model Setup: create boundary condition lines and assign boundary 
conditions 

• Run: run SRH-2D model (currently not available) 

• Contour: add contour map from post-process file (currently not available) 

• Vector: add vector map from post-process file (currently not available) 

• Option: set display options 
 

2.2. Module Indicator 
SRH-Mesh’s module shows the set up and program modules.  

 

Setup module is used to set up general model parameters, 
boundary conditions, initial conditions for unsteady 
simulations, and sediment size classes and bed gradations for 
mobile bed simulation. 

 

BC line module is used to create boundary and monitoring 
lines and assign boundary conditions. 

 

Mesh module (individual mesh) is used to select lines to 
create mesh, assign bed roughness, etc. 

 

Mesh module (global mesh) is used to assign bed roughness, 
bed gradation zone, initial condition zone, etc. 

 

Polylines delineate the sides of a mesh. The Geometry 
module is used to delineate polylines, edit nodes in 
polylines, redistribute nodes in polylines, and join polylines.  
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GIS module is used to input GIS shapefiles. 

 
Image module is used to input images with GIS projections. 

The status box currently provides the x and y coordinates of the mouse point. 
Note that two other modules are under development: 

 

Vector module will be used to create velocity vector map 
for 2D numerical simulation. 

 

Contour module will be used to create contour map for 2D 
numerical simulation. 

 

2.3. Table of Contents 
SRH-Mesh’s table of contents, as displayed in Figure 2-3, provides an easy click 
to turn the workspace contents on or off. The first layer of table of contents shows 
the modules available in the SRH-Mesh program. When you click a module in the 
table of contents, the program will switch to the corresponding module. 
 
 If there is a plus + sign to the left of the contents, then user-created subfiles are 
available under that content line. For example, if you add four GIS shapefiles to 
the program, then there will be four sub-contents with the shapefile names under 
GIS, and you can switch each shapefile on and off. You can expand the table of 
contents on the plus sign to the left of the contents to show the sub-contents.  
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Figure 2-3. SRH-Mesh’s table of contents. 

2.4. Tool Buttons 
Tool buttons are just under the menu. When a module is clicked in the table of 
contents, the tool buttons are updated for that module. Eight zoom buttons are 
followed by a serial of buttons for each module.  

2.4.1. Zoom Buttons 
The same zoom tools for all four modules followed by different buttons for each 
module (Figure 2-4.  

 
Figure 2-4. Zoom buttons. 

Each button provides a different function: 

 
Zoom to the map’s extent 

 
Zoom into map 

 
Zoom out of map 

 
Specify viewport by mouse selection 

 
Drag the map's content around and scroll by mouse wheel 

 
Zoom to previous viewport 
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Zoom to next viewport 

 Set the view scale 

2.4.2. Image Module Buttons 
When you click the Image Module in the table of contents, the Image Module 
toolbar will appear next to the zoom buttons (Figure 2-5): 

 
Figure 2-5. Command buttons for Image Module. 

 Each button provides a different function. 

 
Label to show image module 

 
Add an image from file 

 
Remove selected image from project 

 
Display general information for selected image geometry in the 
context table (file name and source, projection, size, and envelope) 

Currently SRH-Mesh can input images in tif, img, and ecw formats. All input 
images should be GIS referenced. 

2.4.3. GIS Module Buttons 
When you click the GIS Module in the table of contents, the GIS Module toolbar 
will appear next to the zoom buttons (Figure 2-6): 

 
Figure 2-6. Command buttons for GIS Module. 

Each button provides a different function: 

 
Label to show GIS module 

 
Add a GIS shapefile to the project 

 
Remove selected GIS shapefile from project 

IMG 

GIS 

IMG 

GIS 
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Transfer selected GIS geometry in the context table into SRH-Mesh 
geometry 

 
Display general information of selected GIS geometry in the context 
table (file name, projection, type, size, and envelope) 

 
Format display of the geometry (line width and color, point size and 
color, polygon fill color) 

2.4.4. Geometry Module Buttons 

2.4.4.1 Create and Edit Geometry 

When you click the Geometry Module (GEM) in the table of contents, the 
Geometry Module Toolbar will appear next to the zoom buttons: 

 
Figure 2-7. Command buttons for the Geometry Module. 

Each button provides a different function. 

 
Label to show geometry module. 

 
Select a line. 

 
Remove all selections. 

 
Add geometry by mouse click. 

 
Edit geometry lines. 

 
Move/rotate geometry lines 

 
Merge/split geometry lines. 

 
Split geometry lines at all intersections. 

 
Show geometry information. When no line is selected, a window 
shows information about all lines: total line numbers, maximum 
line length, minimum line length, maximum number of vertexes, 
and minimum number of vertexes. When a line is selected, a 
window shows information about the selected line and coordinates 
of the line. 

GEM 

GEM 
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Format display of the geometry (line and node size and color). 

2.4.4.2 Edit Polylines 

When you click the edit geometry button , the Edit Tools Module toolbar 
(Figure 2-8), which is used to edit the selected polylines (Sections 3.3.4 to 
3.3.11). 

 
Figure 2-8. Command buttons for the Edit Tools Module to edit lines. 

Each button provides a different function. 

 
Select the geometry line(s) to be edited. Press Ctrl to add or 
remove the selection to previous selections. Press Alt to add 
the selection to previous selections—even if that selection is 
already in the previous selections. 

 
Deselect all features. 

 
Delete selected polyline(s). 

 
Redistribute selected polyline(s) and input the number of 
vertexes. 

 
Edit the selected vertex by input x and y coordinates. 
Coordinates can by input directly or by an equation. For 
example, if you input “=x-100” in the x textbox, the selected 
vertex will be moved by 100 units (e.g., feet) to the left. 

 
Move a vertex: use the mouse to drag the selected vertex into 
a new location. 

 
Insert a new vertex by clicking on it. 

 
Delete a vertex by clicking on it. 

 
Save edited geometry. 

 
Save edited geometry and exit the Edit Geometry Module. 

Delete 

Redis
t 

Edit Vert 

Move Vert 

Ins Vertex 

Del Vert 
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Exit the Edit Geometry Module without saving the edits. 

2.4.4.3 Move or Rotate Polylines 

When you click the Move/Rotate button , the program enters the Move/Rotate 
Module toolbar (Figure 2-9, which are used to move, rotate and scale the selected 
polylines (Sections 3.3.12 to 3.3.15). 

 
Figure 2-9. Command buttons for moving, rotating, and scaling geometry. 

Each button provides a different function. 
 

 
Select the geometry to be moved/rotated. Press Ctrl to 
add or remove the selection to previous selections. 
Press Alt to add the selection to previous selections—
even if that selection is already in the previous 
selections. 

 
Deselect all features. 

 
Move selected polylines by inputting x and y 
distances, or use the + or – key on your keyboard to 
shift the selected polylines to the left (-) or right (+). 
You can keep the original polylines. 

  
Move the selected polyline by dragging it to a new 
location. 

 

Select the rotate point.  

 
Rotate/scale selected polylines with respect to the 
rotate point. The rotate is input in a range from 0o to 
360 o. You can keep the original polylines. 

 
Save edited geometry. 

 
Save edited geometry and exit the Move/Rotate 
Module. 

 
Exit the Move/Rotate Module without saving the edits. 

Move 

Move with Mouse 

Select Rotate 
Point 

Rotate/Scale 
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2.4.4.4 Merge or Split Polylines 

When you click the Merge/Split button , the program enters the Merge Tools 
Module (Figure 2-10,) which is used to merge, split, group, and ungroup the 
selected polylines (Sections 3.3.16 to 3.3.20). 

 
Figure 2-10.  Command buttons for merging, splitting, and grouping geometry lines. 

 
Each button provides a different function. 

 
Select the geometry lines to be merged/grouped. Press 
Ctrl to add/remove selections, press Alt to add 
selections.  

 
Deselect all features. 

 
Merge selected geometry into one feature. 

  
Split the selected geometry by clicking a vertex. 

 

Split the selected geometry at all intersection(s). 

 
Group selected geometries into one group. The 
polylines in the same group can be treated as one of 
four sides in a quadrilateral mesh. 

 
Ungroup selected geometries into one group. The 
polylines in the same group can be treated as one of 
four sides in a quadrilateral mesh. 

 
Save geometry. 

 
Save edited geometry and exit the Merge Tools 
Module. 

 
Exit the Merge Tools Module without saving the edits. 

Merge 

Split at Vertex 

Split at 
Intersection 

Group 

Ungroup 
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2.4.5. Individual and Global Mesh Module Buttons 
SRH-Mesh can create four types of meshes:  

• Triangle meshes contain only triangles from Delaunay triangulations 
resulting from arbitrary boundaries and inside lines or holes.  

• Quadrilateral meshes are created as structure grid using four boundary 
lines (which can be combined from more than four lines). If there are 
uneven vertexes between opposite side lines, then a triangle cell can be 
inserted to transit from one side to another side of domain.  

• Mixed meshes are created by merging neighbor triangle cells into 
quadrilateral cells. The resulting mesh contains most quadrilateral cells 
with limited triangle cells that can’t be merged with other cells, or if it is 
merged the quadrilateral cell is too irregular.  

• Voronoi meshes can be created, but if one Voroni mesh is created, then 
the final mesh should contain all Voronoi cells.  

 
When you click the Mesh Module (M), the Mesh Module toolbar will appear next 
to the zoom buttons (Figure 2-11):  
 

               

 
          

    

Figure 2-11. Command buttons for the Mesh Module. 

Each button provides a different function. In the model, all buttons are presented 
in a single line. Some of the buttons are available only when needed. 

 Label to show global mesh module. 

 Label to show individual mesh module. 

 Select a single side or multiple sides for mesh generation. 

 
Select an inside line or multiple insider lines for mesh 
generation. 

 Select a single or multiple hole line(s) for mesh generation. 

 
Create a triangle mesh with selected sides, inside lines 
(optional), and hole lines (optional). 

MHG 

MHG 

MHI 
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 Create a quadrilateral mesh with selected side lines. 

 
Create a mixed mesh with selected sides, inside lines 
(optional), and hole lines (optional). 

 
Create a Voronoi mesh with selected sides, inside lines 
(optional), and hole lines (optional). 

 Select a single or multiple mesh domain(s). 

 Select a single or multiple mesh cell(s). 

 Select a single or multiple mesh vertex(es). 

 Remove all sections. 

 Remove selected mesh(s). 

 Show individual meshes. 

 Show global mesh. 

 Change the bed roughness zone in selected mesh(s). 

 Change select bed roughness zone in selected mesh cell(s). 

 
Change the sediment gradation zone in selected mesh(es). 
This button is only available for the morphology solver. 

 

Change the selected sediment gradation zone in selected 
mesh cells. This button is only available for the morphology 
solver. 

 

Change initial zone in selected mesh(s). This button is only 
available for the unsteady flow or morphology solver with an 
initial condition input at each zone. 
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Change initial zone in selected mesh cells. This button is 
only available for the unsteady flow or morphology solver 
with an initial condition input at each zone. 

 

Display the mesh information regarding cell number, vertex 
number, vertex number on the boundary, area, maximum 
area, minimum area, maximum angle, and minimum angle of 
cells. 

 

Set mesh display properties. You can choose the size and 
color of mesh lines, boundary lines, mesh fills for different 
zones of bed roughness, bed gradation, and initial condition.  

 

Refresh the mesh after the elevation was changed. Mesh 
elevation is changed on mesh vertexes in each individual 
mesh, and the global mesh elevation will be updated only 
when the refresh button is clicked.  

 Save the created mesh in .srhm format. 

2.4.6.  Boundary Condition Line Module Buttons 
When you click the BC Line Module in the table of contents, the BC Line Module 
Toolbar will appear next to the zoom buttons (Figure 2-12). 
 

             

Figure 2-12. Command buttons for the  BC Line Module. 

Each button provides a different function. 

 
Label to show BC Line Module.  

 
Select a boundary condition line to be removed or to assign 
boundary conditions. 

 
Deselect all features including boundary condition lines. 

 
Add a boundary condition line. 

 
Add an internal monitoring line. 

BCL 

BCL 
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Remove boundary condition lines or monitoring lines. 

 
Add a monitoring point. 

 
Remove a monitoring point. 

 
Display a summary of all boundary condition lines. 

 
Display a summary of boundary condition lines (name, 
boundary condition type, boundary condition index).  
The unused boundary conditions are also shown. 

 
Display a summary of monitoring point(s). 

 
Set the boundary condition line display properties. You can 
choose the size, color, and pattern for the boundary condition 
lines, and the boundary condition line label font.  

 
Save the created mesh in .srhm format. 

All points of boundary condition lines are located on the external boundary of the 
final global mesh, and all points of monitoring lines are located inside of the 
global mesh. Monitoring lines can also be used to setup internal boundary 
conditions. To create the boundary condition lines, first click the add a boundary 
condition line button  and then use the mouse to select vertexes. SRH-Mesh 
will add boundary vertexes between the selected vertexes to create the boundary 
condition line. To create the insider monitoring lines, first click the add an 
internal monitoring line button  and then use the mouse to select inside 
vertexes. To finish adding vertexes to a boundary condition line or a monitoring 
line, double-click the last vertex as the end of the line. SRH-Mesh will add 
vertexes between the selected vertexes to create a monitoring line that has the 
shortest distance between the selected vertexes. To delete a created boundary 
condition line or monitoring line, first click remove boundary condition lines or 

monitoring lines button , then click the line you want to delete. To add a 
monitoring point, first click the add a monitoring point button , then click the 
vertex as a monitoring point. To remove a monitoring point, first click remove a 
monitoring point button , then click the monitoring point.  
 
To assign or edit the boundary condition for a boundary condition line, first select 
a boundary condition line. Then right-click to bring up the context menu strip 
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where you can edit the current boundary condition, add a new boundary 
condition, assign an existing boundary condition to the line, or delete the 
boundary line. To select a boundary condition line, you can use the select button 

 and then click the line directly, or you can double-click the line in the table of 
contents.  

2.5. Status Line 
The status line includes textboxes for x, y, and z coordinates as well as a message 
box for program status (Figure 2-13). While the mouse is moving in the 
workspace, the mouse coordinates are listed in the x and y textboxes. When some 
mesh vertexes are selected, the first mesh vertex coordinates are listed in the x, y, 
and z textboxes. The user can also change the elevation of selected mesh vertexes 
directly by inputting new z coordinate in the text box. The message box provides 
the program’s running information.  

 
Figure 2-13. Status line.
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3. Modules 
3.1. Image Module 
Click Image in the table of contents to switch to the Image Module toolbar (Figure 3-1). 

The icon for the Image Module will appear in the lower left corner of the workspace . 

 
Figure 3-1. Command buttons for the Image Module. 

3.1.1. To Add an Image 

1. Click the add button   
2. Select an image file from a file browser 
3. Click the open button 

If you are using an image exported from GIS, perform the following steps to ensure that 
the image is readable and can be correctly projected in SRH-Mesh: 

 In ArcMap 
 Select File>Export Map 
 Save as type: TIFF(*tif) 
 Make sure “Write World File” is selected. 
 Save 

 
 In Arc Cetology 
  Right-click the created image file (*tif)>Properties 
 Selects Spatial Reference>Edit 
 Select or add the corrected coordinate system. 

3.1.2. To Remove an Image 
1. Select the image from the table of contents under Image 

2. Click the remove  button  

3.1.3. To Display an Image Information 
1. Select the image from the table of contents under Image 

2. Click the information  button 

IMG 
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3.2. GIS Module 
Click GIS in the table of contents to switch to GIS Module toolbar (Figure 3-2). The icon 

for the GIS Module will appear in the lower left corner of the workspace.   
 

 
Figure 3-2. Command buttons for the GIS Module. 

3.2.1. Add an GIS Shapefile 

1. Click the add GIS file button  
2. Select the GIS file from a file browser 
3. Click the open button 

3.2.2. Remove a GIS 
1. Select the GIS Module toolbar from the table of contents under GIS 

2. Click the remove GIS file button  

3.2.3. Display a GIS Shapefile Information 
1. Select the GIS Module toolbar from the table of contents under GIS 

2. Click information button  

3.2.4. Convert a GIS Shapefile into SRH-Mesh Geometry 
1. Select a GIS shapefile with a yellow background color from the table of contents under GIS. If the 

background of the shapefile name in the table of contents is white, then it has already been 
converted into SRH-Mesh Geometry. If you want to convert the shapefile again, you need to 
remove the GIS shapefile and add it into the project again.  

2. Click the transfer GIS geometry button  

3.2.5. Display a GIS Shapefile Information 
1. Select a GIS shapefile from the table of contents under GIS 

2. Click the information button  

3.2.6. Reset GIS Display Options 

1. Click the format display button  
2. Set all display options: 

a. Line style, width, and color 
b. Point style, size, and color 
c. Polygon fill color 

3. Click the yes button to reset the GIS display options or the no button to cancel the 
action 

GIS 
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3.3. Geometry Module 
Click Geometry in the table of contents to switch to Geometry Module toolbar (Figure 3-3). The 
icon for the Geometry Module will appear in the lower left corner of the workspace . 

 
Figure 3-3. Toolbar for editing geometry. 

Note that lines can be created from the points that are part of the SRH-Mesh geometry. 
However, they can’t be edited in the SRH-Mesh.  

3.3.1. Select a Geometry Line 

1. Click the select line button  
2. Mouse to the line(s) you want 

a. Click to select a line 
b. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 

selection(s) 
c. Click and drag to select all lines in the drag box 

3.3.2. Deselect All Lines 

Click the deselect all button  to deselect all lines in the Geometry, Mesh, and Boundary 
Condition Line Modules. 

3.3.3. Add a Geometry Line Using the Mouse 
1. Select Geometry>Snap on (off) to set the option if you want to snap the line to a 

vertex of another line or a geometry point (optional). 
2. Select Geometry>Snap Distance = ## Pixels to set the snap distance (optional). A 

form will appear to set the snap distance. If the distance is greater than the snap 
distance on the screen, then the new vertex would not be snapped to any vertex or 
point.  

3. Click the add line button . 
4. Click to add a line in the workspace. 

5. You can use the zoom buttons: zoom to the map’s extent , zoom into the map 

, zoom out of the map , zoom to a previous viewport , and zoom to 

the next viewport . You may also click and drag to move the map around and 
use mouse wheel to zoom into and out of map. 

6. Double-click to finish adding a line. 

GEM 
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3.3.4. Add Points from a Text File 
Select Geometry> Input Text File as Points. A form will appear (Figure 3-4). 

 
Figure 3-4. Input points from text file. 

1. Select a file with extension .csv, .txt, or .dat from a file browser 
2. Input the parameters 

a. X: column for the x coordinate 
b. Y: column for the y coordinate 
c. Z: column for the z coordinate (optional) 

3. Click the yes button to input the text file or the no button to cancel the action 

3.3.5. Add Lines from a Text File 
1. Select Geometry>Input Text File as Polylines. A form will appear (Figure 3-5). 

 
Figure 3-5. Input lines from text file. 

2. Select a file with extension .csv, .txt, or .dat from a file browser 
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3. Input the parameters 
a. X: column for the x coordinate 
b. Y: column for the y coordinate 
c. Z: column for the z coordinate (optional) 
d. Group By: Select from the drop down menu. For example, selecting to group 

by ID would group all the points with same ID would be in a single line 
4. Click the yes button to input the text file or the no button to cancel the action 

3.3.6. Delete a Line 

1. Click the edit line button  to bring up the editor  toolbar if the editor controls 
(Figure 3-6) are not shown.  

 
Figure 3-6. Toolbar for editing lines. 

2. Click the select a line button  in the editor  toolbar and select the line(s) to be 
deleted. 

3. Click the delete button  to delete selections. 

4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.7. Redistribute Line 

1. Click the edit line button  to enter editor  toolbar if editor controls (Figure 3-6) 
are not shown.  

2. Click the select line button  in the editor  toolbar and select the line(s) to be 
redistributed. 

3. Click the redistribute button . A form will appear (Figure 3-7). 

Delete 

Redist 
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Figure 3-7. Geometry line redistribution form. 

4. Input the parameters. 
a. Node Number: total number of vertexes. 
b. Last/First Ratio: the ratio of the last segment length to first segment length. 
c. Neighbor Ratio: the ratio of length of segment i+1 to length of segment i. 
d. Cell Length: cell length of each segment. The line will be equally distributed. 
e. Refine: The line will be refined according to input ratio. 

5. Options to redistribute the line(s). 
a. Click the yes button to perform the defined redistribution task or the no button 

to cancel the action 
b. Click the revise ratio button to recalculate the Last/First or Neighbor Ratio as 

the reciprocal of the ratio and perform the redistribution task 
c. Click the revise direction button to redistribute the line according to input 

parameters, then reverse the direction of the line 

6. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit 
the editor  toolbar or click the cancel button  to exit editor  toolbar without 
saving.  

3.3.8. Edit a Vertex in a Geometry Line 

1. Click the edit line button  to enter editor  toolbar if editor controls (Figure 3-6) 
are not shown.  
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2. Click the select line button  in the editor  toolbar and select the line to be edited. 

3. Click the edit vertex button . 
4. Click to select the vertex from the line to be edited. 
5. In the x, y, or z text box in the Status Line, input the new x, y, or z value. 

a. Input x, y, or z coordinate in the format of ####.## (e.g., 1234567.89) 
b. Input relative coordinates in the x, y, or z textbox (e.g., if you input  

“=y-100” as y coordinate, then the y coordinate will be decreased by 100) 

7. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving.  

3.3.9. Move a Vertex 

1. Click the edit line button  to enter editor toolbar if editor controls (Figure 3-6) 
are not shown.  

2. Click the select line button  in the editor  toolbar and select the line to be edited. 

3. Click the move vertex button  . 
4. Click to select the vertex to be moved and drag it to the target location. 

5. Continue to edit geometry lines, or the save button to save edited geometry, or 
click the save and exit button  to save edited geometry and exit the editor  
toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.10. Insert a Vertex 

1. Click the edit line button  to enter editor  toolbar if editor controls (Figure 3-6) 
are not shown.  

2. Click the select line button  in the editor  toolbar and select the line to be edited. 

3. Click the insert vertex button . 
 

4. Click on the point where you want to insert the new vertex. The new vertex can 
only be inserted into the original line. 

5. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

Edit Vertex 

Move Vert 

Ins Vert 
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3.3.11. Delete a Vertex 

1. Click the edit line button  to enter editor  toolbar if editor controls (Figure 3-6) 
are not shown.  

2. Click the select line button  in the editor  toolbar and select the line to be edited. 

3. Click the delete vertex button . 
 

4. Click on the vertex to be deleted. 

5. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.12. Move a Line 

1. Click the move line button  in the Geometry Module toolbar (Figure 3-8) to 
enter the move/rotate toolbar if this toolbar is not shown (Figure 3-8). 

 
Figure 3-8. Toolbar for moving, rotating, and scaling geometry. 

2. Click the select line button  in the editor toolbar and select the line(s) to be 
moved. 

3. Click the move button . A form will appear (Figure 3-9). 

Del Vert 

Move 
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Figure 3-9. Form to move a line. 

4. Input the parameters. 
a. X Y Directions: Distances along the x and y coordinates to move the line. 
b. Node Coordinates: These coordinates define how much the line will be 

shifted parallel to the original line. A positive value would shift the line to the 
right direction and a negative value would shift the line to the left direction. 

c. Keep the Original: This determines if you want to move the line to a new 
direction while also keeping the original line. 

5. Click the yes button to perform the action or the no button to exit the form. 

6. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.13. Move a Line with the Mouse 

1. Click the move line button  to enter move/rotate  toolbar if the move/rotate 
controls (Figure 3-8) are not shown. 

2. Click the select line button  in the editor  toolbar and select the line(s) to be 
moved. 

3. Click the move with mouse button  and drag the line to a 
new location. 

Move with Mouse 
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4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.14. Select a Rotate Point to Rotate/Scale a Line 
When you want to rotate a line or scale a line, first select a rotate point. You can move or 
scale multiple lines at the same time with the same rotate point. If you do not select a 
rotate point, the center of all lines will be used as a rotate point. The x and y coordinates 
can be modified in the Rotate/Scale form by inputting new values. 

1. Click the move line button  to enter the move/rotate  toolbar if move/rotate 
controls (Figure 3-8) are not shown. 

2. Click the select-line button  in the editor  toolbar and select the line(s) to be 
moved. 

3. Click the rotate point button . 
4. Click a vertex in the line as the rotate point. 
5. Rotate/Scale a Line (Section 3.3.15).  

Rotate Point 
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3.3.15. Rotate/Scale a Line 
When you want to rotate a line or scale a line, select a rotate point (3.3.14).  

1. Click the move  button in the Geometry Module toolbar (Figure 3-3) to enter 
the move/rotate toolbar if the move/rotate controls are not shown (Figure 3-8). 

2. Click the rotate/scale button . A form will appear (Figure 3-10). 

 
Figure 3-10. Rotate or scale a line. 

3. Input the parameters. 
a. Rotating point x and y: x and y coordinate where the line(s) would be rotated 

or scaled. 
b. Rotating angle: angle with which the line(s) would be rotated. A negative 

value between -180o to 0o (clockwise) or a positive value from 0 to 360o 
(counterclockwise) is allowed. Quick buttons of 90o, 180o, and 270o are 
provided.  

c. Scale factor: value to scale the line(s). A value between 0.10 to 10 is allowed. 
Quick buttons of 50%, 100%, 150%, 200%, 300%, and 400% are provided.  

d. Keep the original: This determines if you want to rotate/scale the line(s) while 
also keeping the original line. 

4. Click the yes button to perform the action or the no button to cancel the action. 

5. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving.  

3.3.16. Merge Lines 

1. Click the merge/group button  to enter merge/group  toolbar if merge/group 
controls (Figure 3-11) are not shown. 

Rotate/Scale 
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Figure 3-11. Toolbar for merging, splitting, and grouping geometry. 

2. Click the select line button  in the editor  toolbar and select the line(s) to be 
merged. 

3. Click the merge button . 

4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.17. Split a Line 
1. Click the merge/group button  to enter merge/group  toolbar if merge/group 

controls (Figure 3-11) are not shown. 
 

2. Click the select line button  in the editor toolbar and select the line(s) to be 
merged. 

3. Click the split button . 
 

4. Click a vertex where you want to split the line. 
 

5. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 
 

3.3.18. Split lines at Intersection(s). 
 

1. Click the merge/group button  to enter merge/group toolbar if merge/group 
controls (Figure 3-11) are not shown. 
 

2. Click the select line button  in the editor toolbar and select the line(s) to be 
merged. 

3. Click the split at intersection button . 
 

4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

 

Merge 

Split 

Split at Intersection 
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3.3.19. Group Lines for a Quadrilateral Mesh 
Only four lines are required for four sides of a quadrilateral mesh. If there are more than 
four lines selected as a boundary for a mesh, SRH-Mesh automatically detects the shape of 
the boundary and determines how to group several lines into one side of the mesh. If you 
want to use another way to composite a side of a mesh, you can group these connected 
lines by setting a same group number for the connected lines. Following these steps to 
group lines. 
 

1. Click the merge/group button  to enter merge/group  toolbar if merge/group 
controls (Figure 3-11) are not shown. 
 

2. Click the select-line button  in the editor  toolbar and select the line(s) to be 
merged. 

3. Click the group button . 
 

4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

 

3.3.20. Ungroup Lines for a Quadrilateral Mesh 
If you do not like the way that you grouped the lines, following these steps to ungroup 
lines. 

1. Click the merge/group button  to enter merge/group  toolbar if merge/group 
controls (Figure 3-11) are not shown. 

2. Click the select-line button  in the editor  toolbar and select the line(s) to be 
group. 

3. Click button . 

4. Continue to edit geometry lines, or click the save button to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving. 

3.3.21. Split Lines at all Line Intersections 

Click the split-lines button . 

3.3.22. Display Geometry Information 

Group 

Ungroup 
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1. Select the GIS shapefile from the 
table of contents under the GIS 
menu item 

2. Click the information button  to 
display geometry information 
a. If no line is selected, 

information about all lines is 
displayed (Error! Reference 
source not found.) 

• Line Number: total 
number of lines 

• Max Length: the length 
of line with maximum 
length 

• Min Length: the length 
of line with minimum 
length 

• Max Vertex Number: 
number of vertexes in the 
line with maximum vertexes 

• Min Vertex Number: number of vertexes in the line with minimum 
vertexes 

b. If you select a line, a form will appear (Figure 3-13).  
c. Click the Info and Coordinate tabs to switch between line information and 

coordinates. The Coordinate tab provides x, y, and z coordinates. The Info tab 
contains: 

Figure 3-12. Information for all lines. 

 



SRH-Mesh 1.0 User’s Manual  
Modules 
 

30 

  

Line Information Line Coordinates 

Figure 3-13. Information for a single line. 

• ID: line ID 
 

• Group: line group number 
 

• Line Type: GIS input lines, created lines, large wood structure line, 
large wood structure boundary line, or large wood structure linkage line 
 

• Length: length of line 
 

• Max Cell Length: maximum cell length 
 

• Min Cell Length: minimum cell length 
 

• Max Elevation: maximum elevation 
 

• Min Elevation: minimum elevation 
3. Click the close button to close the form. 
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3.3.23. Display Geometry Summary 
1. Select a GIS shapefile from the table of contents under GIS 

2. Click the summary button  to display all of the line information (Figure 3-13) 
3. Click the close button to close the form 

3.3.24. Set Geometry Display Options 

1. Click the set-display button . A form will appear (Figure 3-14). 

 
Figure 3-14. Geometry format. 

2. Input parameters: 
a. Line style, width, and color 
b. End node style, size, and color 
c. Middle node style, size, and color 
d. Point geometry style, size, and color 

3. If needed, click the reset button to return default setting. 
4. Click the yes button to save the geometry display options or the no button to cancel 

the action. 

3.3.25. Create Mesh from all Geometry 
Select Geometry>Create Mesh with All Geometry Lines or Mesh>Create Mesh with All 
Geometry Lines.  
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3.3.26. Export All Geometry Lines into a GIS Shapefile 
Select Geometry>Export to GIS ShapeFile and the shapefile is saved as 
C:\TEMP\ExportShapefile.shp. 

3.3.27. Insert a Simplified Large Wood Structure 
SRH-Mesh enables you to add six types of pre-defined simplified large wood structures 
(Figure 3-15).  

 
Figure 3-15. Six types of pre-defined simplified large wood structure. 

Follow the following steps to add a large wood structure. 
1. Select Geometry>Insert Simplified Large Wood Structures. 

 
2. Click a point in the workspace where you want to insert the beginning of the 

structure, hold and drag the mouse to a new point where you want to insert the end 
of the structure. The direction from the first to second point represents the 
orientation of the large wood structure.  The middle point of your mouse “hold and 
drag” represents the center of the large wood structure.  A form will appear ( 
Figure 3-16). 
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Figure 3-16. Form to pick the type of simplified large wood structure and set the dimension of 
the structure. 

3. Select one of the six types of pre-defined simplified large wood structures in the 
form. The form will change its representing figure into the selected structure 
(Figure 3-16) and provide parameter input names and NumericUpDown controls 
for the structure.  
 

4. Modify the parameters of the structure in the form if it is needed and check the 
final shape of the structure in the form. 

5. Click the yes button to insert the structure or the no button to cancel the action. 
The top face of the structure, defined by wi and li in Figure 3-16, has a height defined in 
the form. After the mesh is created and the elevation at each mesh vertex is interpolated, 
you can use the Mesh>Set-LWD-Elevation to calculate the vertex elevations of the 
structure to match the surrounding terrain elevation and defined structure height.  



SRH-Mesh 1.0 User’s Manual  
Modules 
 

34 

3.3.28. Insert a More Complex Large Wood Structure 
SRH-Mesh enables you to add four types of more complex pre-defined large wood 
structures (Figure 3-17).  

 
Figure 3-17. Form to select the type of large wood structure and set the structure’s dimensions. 

To add a large wood structure: 
1. Select Geometry>Insert Large Wood Structures. 

 
2. Click a point in the workspace where you want to insert the beginning of the 

structure, hold and drag to a new point where you want to insert the end of the 
structure. The direction from the first to second point represents the orientation of 
the large wood structure.  The middle point of your mouse “hold and drag” 
represents the center of the large wood structure.  A form will appear (Figure 
3-17). 
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Figure 3-18. Form to pick the type of large wood structure and set the dimensions of the 
structure. 

3. Select one of the four types of more complex pre-defined large wood structures in 
the form. The form will change its representing figure into the selected structure 
(Figure 3-18) and provide parameter input names and NumericUpDown controls 
for the structure.  
 

4. Modify the parameters of the structure in the form if it is needed and check the 
final shape of the structure in the form. 
 

5. Click the yes button to insert the structure or the no button to cancel the action. 
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3.4. Individual and Global Mesh Module 
Click Mesh in the table of contents to switch to Mesh Module toolbar (Figure 3-19). The icon for 

the Mesh Module will appear in the lower left corner of the workspace: individual  and 
global . 
 

               

 
          

    

Figure 3-19. Mesh Module toolbar..  

3.4.1. Select Outside Line(s) for Mesh 
Selected outside lines are displayed in cyan. To create a mesh, make sure that all outside 
lines are connected to form one or polygons.  

1. Click select outside line button  
2. Use mouse to select the line(s) 

a. Click to select a line 
b. Press Ctrl + click to add or remove selection(s). Press Alt + click to add 

selection(s) 
c. Click and drag to select all of the lines in a drag box 

3.4.2. Select Inside Line(s) for Mesh 
Inside lines should not intersect with outside lines or hole lines. Selected inside lines are 
displayed in yellow. Inside lines are used for triangle meshes, mixed meshes, or Voronoi 
meshes where each node on an inside line is a vertex in the resulting mesh. Inside lines are 
ignored by the quadrilateral mesh generator.  

1. Click the select inside line button  
2. Use mouse to select the line(s) 

a. Click to select a line 
b. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 

selection(s) 
c. Click and drag to select all lines in the drag box 

3.4.3. Select Hole Line(s) for Mesh  
Hole lines should not intersect with outside lines or inside lines. Selected hole lines are 
displayed in brown. Hole lines are used for triangle meshes, mixed meshes, or Voronoi 
meshes where holes are present. Hole lines are ignored by quadrilateral mesh generator. 

MHG 
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To create a mesh, make sure that all hole lines are connected to form one or more 
polygons.  

1. Click the select hole line button  
2. Use mouse to select the line(s). 

a. Click to select a line 
b. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 

selection(s) 
c. Click and drag to select all of the lines in a drag box 

3.4.4. Create a Triangle Mesh  
1. Select outside lines (Section 3.4.1), inside lines (optional) (Section 3.4.2), and hole 

lines (optional) (Section 3.4.3). 
2. Make sure that all outside lines are connected to form one or more polygons. 
3. Make sure that all hole lines are connected to present one or more polygons.  
4. Make sure that inside lines do not have any intersections with outside lines and 

hole lines. 

5. Click the triangle-mesh button . 
6. Check the quality of the mesh. To improve the quality of the mesh, right click 

line(s) for the mesh, and a form for line redistribution appears. Refer to Section 
3.3.7 for details of line redistribution. 

3.4.5. Create a Quadrilateral Mesh  
1. Select outside lines (Section 3.4.1).  
2. Make sure that all outside lines are connected to form one or more polygons.  

3. Click the quadrilateral-mesh button . 

4. Check the quality of the mesh. To improve the quality of the mesh, right click 
line(s) for the mesh, and a form for line redistribution appears. Refer to Section 
3.3.7 for details of line redistribution. 

5. Check the sides of the created quadrilateral mesh. If there are more than four lines 
selected as a boundary for a mesh, SRH-Mesh will automatically detect the shape 
of the boundary and determine how to group several lines into a side of the mesh. 
If you want to use another way to composite a side of a mesh, you can group these 
connected lines by setting a same group number for the connected lines. Please 
refer to grouping lines (Section 3.3.19) and ungrouping lines (Section 3.3.20). 

3.4.6. Create a Triangle and Quadrilateral Mixed Mesh  
1. Select outside lines (Section 3.4.1), inside lines (optional) (Section 3.4.2), and hole 

lines (optional) (Section 3.4.3).  
2. Make sure that all outside lines are connected to form one or more polygons. 
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3. Make sure that all hole lines are connected to form one or more polygons.  
4. Make sure that inside lines do not have any intersections with outside lines and 

hole lines. 
5. Click the mixed-mesh  button. 
6. Check the quality of the mesh. To improve the quality of the mesh, right click 

line(s) for the mesh, and a form for line redistribution appears. Refer to Section 
3.3.7 for details of line redistribution. 

3.4.7. Create a Voronoi Mesh 
If one mesh is created as a Voronoi mesh, all meshes should be created as Voronoi. 

1. Select outside lines (Section 3.4.1), inside lines (optional) (Section 3.4.2), and hole 
lines (optional) (Section 3.4.3).  

2. Make sure that all outside lines are connected to form one or more enclosed mesh 
boundaries. 

3. Make sure that all hole lines are connected to form one or more enclosed holes.  
4. Click the Voronoi-mesh  button. 
5. Check the quality of the mesh. To improve the quality of the mesh, right click 

line(s) for the mesh, and a form for line redistribution appears. Refer to Section 
3.3.7 for details of line redistribution. 

3.4.8. Select Mesh(es) 
A mesh or multiple meshes are selected for several purposes: to change the type of the 
mesh, to remove the mesh, to set the bed roughness of the mesh, to set the initial condition 
zone of the mesh, or to set the sediment gradation zone of the mesh.  

1. Make sure that the mesh display mode is of individual mesh. Individual meshes are 
displayed in two places: the label for individual mesh controls is “MHI” and the 
module indicator is . Refer to Sections 3.4.13 and 3.4.14 for details of 
individual mesh and global mesh modes. 

2. Click the select mesh button . 
3. Click on a mesh to select it.  

a. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 
selection(s). 

b. Click and drag to select all of the meshes in a drag box. 

3.4.9. Select Mesh Cell(s) 
Mesh cells are selected for several purposes: to set the bed roughness of the cell(s), to set 
the initial condition zone of the mesh cell (s), or to set the sediment gradation zone of the 
mesh cell(s). Mesh cell (s) can be selected in both individual mesh and global mesh 
modes.  
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1. Click the select mesh cell button  
2. Use a mouse to select the mesh face(s) 

a. Click to select a mesh face 
b. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 

selection(s) 
c. Click and drag to select all of the mesh cells in a drag box 

3.4.10. Select Mesh Vertex and Set Elevation 
A mesh vertex or multiple mesh vertexes are selected only to set the vertex elevation. The 
mesh elevation is changed on selected mesh vertexes in each individual mesh, and the 
global mesh elevation will be updated only when the refresh button is clicked.  

1. Click the select vertex button  
2. Use mouse to select the mesh face(s) 

a. Click to select a mesh face 
b. Press Ctrl + click to add or remove selection(s) and press Alt + click to add 

selection(s) 
c. Click and drag to select all of the meshes in a drag box 

3. Input the new elevation value in the z textbox in the status line, and press the Enter 
key to set the elevation  

3.4.11. Deselect All 

Click the deselect all button  to deselect all in the geometry, mesh, and boundary 
condition modules. 

3.4.12. Delete Selected Mesh 
1. Select the mesh(es) to be deleted 

2. Click the delete mesh button  

3.4.13. Switch to Individual Mesh Mode 
The Individual Mesh mode shows the boundary lines of each mesh. Several mesh 
functions are only available in individual mesh mode (e.g., select the mesh, change mesh 
type, change mesh roughness, change mesh initial condition zone, and change mesh bed 
gradation zone).  
You can switch to the individual mesh mode either by clicking the individual meshes 
button  or on the MHI label in the mesh controls. 
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3.4.14. Switch to Global Mesh Mode 
Global mesh mode shows the final mesh after joining all individual meshes together. The 
boundary lines of each individual mesh are not displayed and only boundary lines of the 
joined mesh are displayed. 2D models, such as the SRH-2D, can only use the global mesh 
mode. 

You can switch to the global mesh mode either by clicking the global mesh button  or 
on the MHG label in the mesh controls. 

3.4.15. Change the Bed Roughness Zone in Selected Mesh(s) 
Make sure that bed roughness is displayed (Section 3.4.22), and individual mesh mode is 
selected (Section 3.4.8).  

1. Refer to Section 3.4.9 to select the mesh(es) of which bed roughness zone will be 
set. 

2. Click the change mesh bed roughness zone button . A form will appear. 
3. Select the bed roughness zone.  

3.4.16. Change the Bed Roughness Zone in Selected Mesh Cell(s) 
Make sure that bed roughness is displayed (Section 3.4.22).  

1. Refer to Section 3.4.9 to select the mesh cell(s) that you want to set the bed 
roughness zone for. 

2. Click the change cell bed roughness zone button . A form will appear. 
3. Select the bed roughness zone.  

3.4.17. Change the Sediment Gradation Zone in Selected Mesh(s) 
The bed gradation zone is only available when the Morphology solver is selected and the 
sediment gradation is set as zone input. Make sure that sediment gradation zone is 
displayed (Section 3.4.22), and individual mesh mode is selected (Section 3.4.13).  

1. Select the mesh(s) (Section 3.4.9) that you want to set the sediment gradation zone 
for. 

2. Click the change mesh sediment gradation zone button . A form will appear. 

3. Select the sediment gradation zone.  

3.4.18. Change the Sediment Gradation Zone in Selected Mesh Cell(s) 
The sediment gradation zone is only available when the Morphology solver is selected, 
and the sediment gradation is set as zone input. Make sure that sediment gradation zone is 
displayed (Section 3.4.22).  

1. Select the mesh cell(s) (Section 3.4.9) that you want to set the sediment gradation 
zone for. 
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2. Click the change cell sediment gradation zone button . A form will appear. 
3. Select the sediment gradation zone.  

3.4.19. Change the Initial Condition Zone in Selected Mesh(s) 
The initial condition zone is only available when the Flow Unsteady or Morphology solver 
is selected, and the initial condition is set as zone input. Make sure that the initial 
condition zone is displayed (Section 3.4.22), and that the individual mesh mode is selected 
(Section 3.4.13).  

1. Select the mesh(s) (Section 3.4.9) that you want to set the initial condition zone 
for. 

2. Click change mesh initial zone button . A form will appear. 
3. Select the initial condition zone.  

3.4.20. Change the Initial Condition Zone in Selected Mesh Cell (s) 
The initial condition zone is only available when the Flow Unsteady or Morphology solver 
is selected, and the initial condition is set as zone input. Make sure that bed roughness is 
displayed (Section 3.4.22).  

1. Select the mesh(s) (Section 3.4.9) that you want to set the initial condition zone 
for. 

2. Click the change cell initial zone button . A form will appear. 
3. Select the initial condition zone.  

3.4.21. Display Mesh Information 

Click the mesh information button  to display mesh information (Figure 3-20). If the 
individual mesh mode is displayed and only one mesh is selected, then information about 
the individual mesh is displayed. If the global mesh mode is displayed or two or more 
meshes are selected, then global mesh information is displayed.  
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Figure 3-20. Mesh information. 

This information is shown: 
• Cell Number: the total number of cells. 

 
• Vertex Number: the total number of vertexes. 

 
• Boundary Vertex Number: the total number of lines in the boundary and number 

of vertexes associated with each line are displayed for an individual mesh. The 
number of vertexes is displayed for global mesh.  
 

• Total Area: the area of the selected mesh. You can right-click the total area button 
to switch the units between square feet (ft2), square meters (m2), and acres. 
 

• Max Cell Area: the area and index of the cell with the largest (maximum) area. 
Click the max cell area button to switch the workspace zoom between the mesh 
and the cell with the maximum area. Double-click the max cell area button to 
zoom the workspace into the cell with maximum area. Right-click the button Max 
Cell Area to switch the units between ft2, m2, and acres. 
 

• Min Cell Area: the area and index of the cell with a minimum area. Click the min 
cell area button to switch the workspace zoom between the mesh and the cell with 
minimum area. Double-click the min cell area button to zoom the workspace into 
the cell with minimum area. Right-click min cell area button to switch the units 
between ft2, m2, and acres. 
 

• Max Cell Angle: the degree of the maximum angle and cell index of the cell with 
that maximum angle. Click the max cell angle button to switch the workspace 
zoom between the mesh and the cell with maximum angle. Double-click the max 
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cell angle button to zoom the workspace into the cell with maximum angle.  
 

• Min Cell Angle: the degree of the minimum angle and cell index of the cell with a 
minimum angle. Click the min cell angle button to switch the workspace zoom 
between the mesh and the cell with minimum angle. Double-click the min cell 
angle to zoom the workspace into the cell with minimum angle.  
 

• Max Elevation: the elevation and index of the vertex with a maximum elevation. 
Click the max elevation button to zoom the workspace into the vertex with 
maximum elevation.  

Click the close button to close the form.  

3.4.22. Set Mesh Display Options 

1. Click the set display button . A form will appear (Figure 3-21). 
2. You can adjust these input parameters: 

a. Line style, width, and color. 
b. Node style, size, and color. 
c. Domain boundary line style, width, and color. 
d. Node index label font and color. 
e. Mesh index label font and color. 
f. Cell index label font and color. 
g. Vertex elevation map option. 
h. Roughness zone name, forecolor, background color, transparency level, and fill 

pattern. Right-click the mouse on the table to add a zone or remove a zone.  
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Figure 3-21. Mesh format. 
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Note: The bed gradation zone is only available when the Morphology solver is 
selected and the sediment gradation is set as zone input. You can adjust the bed 
gradation zone name, forecolor, background color, transparency level, and fill 
pattern. Right-click the mouse on the table to add a zone or remove a zone.  
The initial condition zone is only available when  the Flow Unsteady or  
Morphology solver is selected, and the initial condition is set as zone input. You 
can adjust the initial condition zone name, forecolor, background color, 
transparency level, fill pattern. Right-click the mouse on the table to add a zone or 
remove a zone.  

3. Click the yes button to save the mesh display options or the no button to cancel the 
action. 

3.4.23. Refresh Mesh 
Elevation changes are made only to vertexes in each individual mesh, and the global mesh 
elevation will be updated only when the refresh button is clicked. 

Click the refresh mesh button  to refresh the mesh.  

3.4.24. Save Mesh 
Click the save created mesh button  to save the mesh in the “.srhm” format.  

3.4.25. Refine Mesh 
The refine mesh tool is used only when all meshes are created and you want to change the 
density of the final mesh in a single step. This tool will refine geometry lines (outside 
lines, inside lines, and hole lines) associated with all individual meshes, and refine all 
meshes accordingly. 

1. Select Menu Mesh>Refine Mesh. A form will appear (Figure 3-22). 

 
Figure 3-22. Refine mesh. 
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2. Input the refine ratio. The ratio should be in the range of 50% (where the space 
between original vertexes is doubled) to 400% (where the space between two 
original vertexes is divided into 4 segments). Quick buttons of 50%, 150%, 200%, 
and 400% are provided.  

3. Click the yes button to perform the action and the no button to cancel the action. 

3.4.26. Assign the Roughness Zone with GIS Shapefile 
This tool will assign all mesh cells according to the field selected in the database 
associated with input GIS shapefile. The database file “***.dba” with the same name as 
the shapefile and extension “.dba” is required in the same folder. The GIS shapefile should 
be a polygon (or polygonZ/polygonZM) type. The GIS Shapefile should have the same 
projection with the SRH-Mesh project.  

1. Select Mesh>Assign Roughness Zone with GIS Shapefile. A form will appear 
(Figure 3-23). 

  
Figure 3-23. Assign roughness with GIS polygon field. 

2. Select parameters: 
 
a. Roughness Shapefile: select the GIS shapefile used to assign roughness from 

the drop-down menu or from an open file form 
 

b. Select Roughness: select the roughness index used for all cells within the GIS 
shapefile polygons from a drop-down menu. 
 

3. Click the yes button to perform the action and the no button to cancel the action 

3.4.27. Update Roughness Zone with GIS Shapefile 
This tool will update the roughness zone number in cells only inside the polygons which 
are defined in an input GIS shapefile to a user-defined value. The GIS shapefile should be 
a polygon (or polygonZ/polygonZM) type. The GIS shapefile should have the same 
projection with the SRH-Mesh project.  

1. Select Mesh>Update Roughness Zone with GIS Shapefile. A form will appear 
(Figure 3-24) 
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Figure 3-24. Update roughness with a GIS shapefile. 

2. Input parameters: 
a. Roughness Shapefile: Select the GIS shapefile used to update roughness index 
b. Select Roughness: Select the GIS field used to update roughness index 

3. Click the yes button to perform the action and the no button to cancel the action 

3.4.28. Interpolate Mesh Elevations to Points in a Text File 
1. Select Mesh>Interpolate Mesh Elevations to Points in a File.  
2. Select a text file that contains survey points. The file should contain point data for 

x, y, and z coordinates, separated by space or comma.  The file should also include 
a heading with column names.  The heading should be included in A form will 
appear (Figure 3-25). 

  
Figure 3-25. Interpolate mesh elevations to points in a file. 

 
3. Select columns for x, y, and z coordinates. 
4. Click the yes button to perform the action and the no button to cancel the action. 
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3.4.29. Interpolate Mesh Elevations to GIS Point Shapefile 
1. Select Mesh>Interpolate Mesh Elevations to Survey Points in Shapefile bounded 

by Polygon in Shapefile. A form will appear (Figure 3-26). 

  
Figure 3-26. Interpolate mesh elevations to GIS point shapefile. 

2. Input the data in the form: 
a. Surveyed Point File: the GIS point shapefile representing the survey points 

with x, y, and z coordinates from a drop-down menu or an open-file form. 
b. Interpolate Boundary File: the GIS polygon shapefile representing boundary 

outside of which surveyed points will not be used to interpolate the mesh 
vertex elevations. 

c. Search Range: the vertex elevation will only be interpolated from survey 
points whose distance from the vertex is less than the search range.  

3. Click the yes button to perform the action and the no button to cancel the action. 
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3.4.30. Interpolate Mesh Elevations to GIS Triangulated Irregular 
Network (TIN) File 

1. Select Mesh>Interpolate Mesh Elevations to Survey Points to GIS TIN. A form 
will appear (Figure 3-27). 

  
Figure 3-27. Interpolate mesh elevations to GIS TIN. 

2. Input the data in the form: 
a. GIS TIN file: the GIS TIN file with elevation information from a drop-down 

menu or an open-file form. 
b. Interpolation Method: the method used to interpolate the elevation.  

3. Click the yes button to perform the action and the no button to cancel the action. 

3.4.31. Create Mesh from all Geometry 
Select Geometry>Create Mesh with All Geometry Lines or Mesh>Create Mesh with All 
Geometry Lines. 

3.4.32. Refine All Meshes 

1. Click the edit  button to enter the editor  toolbar if editor controls (Error! 
Reference source not found.) are not shown.  

2. Click the select button  in the editor  toolbar and select the line to be 
redistributed. 

3. Click button , and a form appears (Error! Reference source not found.). Redist 



SRH-Mesh 1.0 User’s Manual  
Modules 
 

50 

 
Figure 3-28. Geometry line redistribution form. 

4. Input the parameters: 
a. Node Number: the total number of vertexes. 
b. Last/First Ratio: the ratio of the last segment length to first segment length. 
c. Neighbor Ratio: the ratio of length of segment i+1 to length of segment i. 
d. Cell Length: the cell length of each segment. The line will be equally 

distributed. 
e. Refine: The line will be refined according to input ratio. 

5. Options to distribute the line(s): 
a. Click the yes button to perform the defined redistribution task or the no button 

to cancel the action.  
b. Click revise ratio button to recalculate the Last/First or Neighbor Ratio as the 

reciprocal of the ratio and perform the redistribution task. 
c. Click the revise direction button to redistribute the line according to input 

parameters, then reverse the direction of the line. 

6. Continue to edit geometry lines, or click the save button  to save edited 
geometry, or click the save and exit button  to save edited geometry and exit the 
editor  toolbar or click the cancel button  to exit editor  toolbar without saving.  

3.5.  Boundary Condition Line Module 
Click BC Line in the table of contents to switch to Boundary Condition Line Module 
toolbar (Figure 3-29). The icon for the Geometry Module will appear in the lower left 
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corner of the workspace .  
 

             

Figure 3-29. Command buttons for the Boundary Condition Line Module. 

Note that only the global mesh is displayed inside Boundary Condition Line module.  

3.5.1. Select a Boundary Condition Line or Monitoring Line 

1. Click the select button  
2. Use the mouse to select the mesh(es).  

a. Click to select a line 
b. Use Ctrl + click to add or remove selection(s) and use Alt + click to add 

selection(s). 
c. Use click and drag to select all lines in the drag box. 

Or  
Double-click the name of the boundary condition line in the table of contents to select the 
line. 

3.5.2. Deselect All 

Click the deselect all button  to deselect all in the geometry, mesh, and boundary 
condition modules. 

3.5.3. Add a Boundary Condition Line 

1. Click the add BC Line button  

2. Click to a vertex at the boundary of the mesh, and the boundary condition line will 
be extended to the new added vertex 

3. Double click to finish adding a line 
4. Input a name for the BC line when prompted 

3.5.4. Add a Monitoring Line 
A boundary condition line is always located on the boundary of the mesh, and a 
monitoring line can lay on the boundary or inside the mesh. No difference is made 
between these two types of lines once they are created, so the monitoring line is also 
called the boundary condition line in SRH-Mesh. 

1. Click the add monitoring line button . 
2. Click a vertex at the boundary or inside of the mesh, and the monitoring line will 

be extended to the new added vertex going through the shortest path. 

BCL 
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3. Double click to finish adding a line. 
4. Input a name for the monitoring line when prompted. 

3.5.5. Delete Selected Boundary Condition Line(s) or Monitoring 
Line(s) 

1. Select the boundary condition line(s) or monitoring line(s) to be deleted (Section 
3.5.1) 

2. Click the remove button  
Or  

1. Click the boundary condition line name in the table of contents to select the line 

2. Click the remove button  

3.5.6. Add Monitoring Point 

1. Click add monitoring point button  
2. Click a vertex and a monitoring point appears 

3.5.7. Delete Monitoring Point 

1. Click the delete monitoring point button  
2. Click an existing monitoring point and that point will be deleted 

3.5.8. Display the Boundary Condition Line and Monitoring Line 
Summary 

Click the display boundary condition lines  button. to display all line information 
(Figure 3-30). Boundary condition line information (in the first table) includes: 

• BC Line: the boundary condition line name.  

• Flow BC Type: the flow type for the boundary condition. If a flow boundary 
condition type has not been assigned, then “BC Not Assigned” is displayed in red.  

• Sed BC Type: the sediment type for the boundary condition. If a sediment 
boundary condition type has not been assigned, then “BC Not Assigned” is 
displayed in red.  

• BC Index: the index of boundary condition associated with the line. If a boundary 
condition has not been assigned to this line, the row is displayed in red. 
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Figure 3-30. Boundary condition line information. 

The boundary condition depends on boundary condition line. If a boundary condition line 
is removed, then the associated boundary becomes unused. Unused boundary condition 
information (in the second table) includes: 

• BC Name: the boundary condition name 

• Flow BC Type: the flow boundary condition type  

• Sed BC Type: the sediment boundary condition type  
Click the yes button to close the form or the no button to cancel the action.  
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3.5.9. Display Monitoring Point Summary 

Click the monitoring point summary button  to display all line information (Figure 
3-31). Monitoring information includes x and y coordinates of all monitoring points. 

 
Figure 3-31. Monitoring point information. 

3.5.10.  
Set Boundary Condition Line Display Options 

1. Click the set display button . A form will appear (Error! Reference source not 
found.).  

 
Figure 3-32 . Boundary condition line format. 

2. Input parameters: 
a. BC Line: the style, width, and color for the boundary condition line 
b. BC Line Label: the font style, size and color for the boundary condition line 

label 
c. Monitor Point: the style, size and color for the monitoring point 
d. Reset: reset to default settings 

3. Click the yes button to save the BC line display options or the no button to cancel 
the action.  
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3.5.11. Save the Boundary Condition Lines 
Click the save button  to save boundary condition lines and monitoring points with 
mesh in “.srhm” format.  

3.5.12. Edit/Add a Boundary Condition to a Boundary Condition Line 
1. Right-click the name of the BC line in the table of contents. A form will appear 

(Figure 3-33).  
2. Select an action from a drop-down menu:  

a. Edit current boundary condition 
b. Add a new boundary condition 
c. Assign an existing boundary condition 

 
Figure 3-33. Boundary condition input form. 

3. Input boundary condition parameters: 
a. Name: Enter a name for the boundary condition 
b. Type: Select flow boundary condition type from drop-down menu 
c. Flow: Enter the related flow boundary condition values 
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3.6. Model Setup 
In the Model Setup menu, click Model Setup. A form will appear (Figure 3-34). 
 
 

  
Figure 3-34. Model setup form. 

1. Input the parameters: 
a. Project Title 
b. Mesh Unit: English or Metric 
c. Solver: Steady flow, unsteady flow, or morphology 
d. Turbulence Model: Depth-averaged parabolic zero-equation model or 

standard two-equation k-ε model 
e. Output Format: Tecplot, SRHC, or SRHN 

2. Click on the Time Step tab and input the parameters (Error! Reference source 
not found.): 
a. Start Time 
b. Time Step 
c. End Time 
d. Output Time Step. 
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Figure 3-35. Time step setup in model setup form. 

3. Click on the Initial Condition tab and input the parameters (Error! Reference 
source not found.). Set the Initial Condition  to dry, auto, restart, zone, or input.  

 
Figure 3-36. Initial condition setup in model setup form. 
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a. If “restart” is selected, a restart file is required.  
b. If “zone” is selected, an initial condition at each zone is required. The initial 

condition zone is defined in Sections 3.4.19 and 3.4.20.  
c. If “point” is selected, an initial condition at each point is required. Note that the 

point initial condition is not available in SRH-2D yet.  
4. Click on the Manning’s tab and input the parameters (Figure 3-37). Input 

Manning’s coefficients for each roughness zone. Refer to Section 3.4.22 to define 
each roughness zone.  
 

 
Figure 3-37. Manning’s coefficients setup in model setup form.
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4. Tools 
This section discusses some of the tools provided in SRH-Mesh menu (Figure 4-1): 

 
Figure 4-1. SRH-Mesh’s menu bar.  

4.1. Find Specific Mesh Node or Cell 
In the View menu, click on Find … . A form will appear (Figure 4-2). 
 

 
Figure 4-2. Find mesh nodes or cells tool.  

You can find a specific mesh cell or node if you have any of the following 
information:  
 

• Node with given node number 
• Node with given x and y coordinates 
• Cell with given cell number 
• Cell with given x and y coordinates 
• Mesh with given mesh number 
• Cell with maximum or minimum cell angles 

 
Select the information type, input the information, and click either Find, Find and 
exit, or Cancel. 
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4.2. Insert Text 
In the Insert menu, click Text and then click a point in the window where you 
want to insert the text box. A form will appear (Figure 4-3). 

 
Figure 4-3. Form to insert a text box. 

You can link the text box with GIS coordinates so when the display zoom is 
changed, the text box is moved to the same location related to GIS, GIS input 
files, and mesh. If you disable the check-box Location Fixed with GIS 
Coordinates, then the text box will fit in the window when the display zoom is 
changed. 
You can use this form to change the font style, size, and color with the font 
button, and you can also change the rotation angle, boundary line, and fill color of 
the text box in the form.  
After a text box is inserted, you can modify it using these options:  

• Format the text box. Double-click the text box to bring the same form 
(Figure 4-3). 

• Format, remove, or duplicate the text box. Right-click the text box.  

• Size the textbox. Slowly move the mouse at the side midpoint or corner of 
a text box. After a size handle appears, grab the sizing handle away from 
or toward the center to increase or decrease the size of the text box. 
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4.3. Insert a Line or a Shape 
In the Insert menu, click Shape and select one of the lines or shapes in the 
submenu (Figure 4-4), then click a point in the window where you want to insert 
the line or shape. You can input text inside of any shape. You cannot put text 
inside or on a line.  

 
Figure 4-4. Submenu to insert a shape 

You can link a shape with GIS coordinates so that when the display zoom is 
changed, the shape moves to the same location relative to GIS, GIS input files, 
and mesh. You can pick one of the nine points (e.g., top left point) in a shape to 
be fixed to a coordinate point in SRH-Mesh.  
If you disable the check-box Location Fixed with GIS Coordinates, the shape will 
fix in the window when the display zoom is changed.  
In the form, you can change the font style, size, and color with the font button of 
the text inside the shape, and you can also change boundary condition line and fill 
color of the shape in the form.  
After a shape is inserted, you can modify it with these options: 

• Format the shape. Double-click the shape to bring a format form (Figure 
4-5). 

• Format, remove, or duplicate the shape. Right-click the shape. 

• Size the shape. Slowly move the mouse at the side midpoint or corner of a 
shape. After a size handle appears, grab the sizing handle away from or 
toward the center to increase or decrease the size of the shape. 
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Figure 4-5. Form to format a shape. 

4.4. Insert Marker 
In the Insert menu, click Marker and then click a point in the window where you 
want to insert the marker. A form will appear (Figure 4-6).  
Select a type of marker in the combo box and a specific design of the marker in 
the drop down box at the top of the form. Markers can be pushpin, sphere, square, 
flag, or place markers—each with different design options.  
You can input text at the right side of a marker.  
You can use the marker form to change the font style, size, and color with the font 
button, and you can also change the size and fill color of the marker in the form.  
After a marker is inserted, you can modify the marker with these options: 

• Format the marker. Double-click the shape to bring a format form ( Figure 
4-6). 

• Format, remove, or duplicate the marker. Right-click the marker. 
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Figure 4-6. Form to insert a marker. 

Size the shape. Slowly move the mouse at the side midpoint or corner of a shape. 
After a size handle appears, grab the sizing handle away from or toward the center 
to increase or decrease the size of the shape. 

4.5. Insert North Arrow 
In the Insert menu, click North Arrow. A form will appear (Figure 4-7).  
Select a specific north arrow in the form, then click the yes button or the no 
button to cancel the action. A north arrow appears in the workspace.  
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Figure 4-7. Form to insert a north arrow. 

After a north arrow is inserted, you can modify it with these options: 
1. Move the north arrow to another place. Click the north arrow, hold it, and 

move it. 
2. Format the north arrow. Double-click the north arrow to bring the format 

form (Figure 4-7). You can change the type of fill color for the north 
arrow here. 

3. Format or remove the north arrow. Right-click it. 
4. Size the north arrow. Slowly move the mouse at the side midpoint or 

corner of the North Arrow. After a size handle appears, grab the sizing 
handle away from or toward the center to increase or decrease the size of 
the north arrow. 

4.6. Insert Scale Bar 
In the Insert menu, click Scale Bar. A scale bar appears in the workspace.  
After a scale bar is inserted, you can modify it with these options:  

1. Move the scale bar to another place. Click the bar, hold it, and drag it.  
2. Format the scale bar. Double-click the scale bar to bring the format form 

(Error! Reference source not found.). You can change the type of the 
combination of the two colors of the scale bar here. You can also change 
the unit, size, font, border line width and color, and the fill color of the 
scale bar here. 
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Figure 4-8. Form to insert a scale bar. 

3. Format or remove the scale bar. Right click the scale bar. 
4. Size the scale bar. Slowly move the mouse at the side midpoint or corner 

of the scale bar. After a size handle appears, grab the sizing handle away 
from or toward the center to increase or decrease the size of the scale bar. 

4.7. Directional Interpolation 
Directional interpolation first calculates the streamwise and transversal 
coordinates for each survey point by projecting each point into channel center 
lines. The tool interpolates points in the streamwise and transversal coordinates 
with a resolution given in the input form (Figure 4-9). The streamwise coordinate 
is the streamline distance of the projected points to the most upstream point, and 
the transversal coordinate is the distance from the survey point to the projected 
point. Directional interpolation uses the nearest point from each quadrant in a 
curvilinear coordinate plane and interpolates the elevation by using the inverse 
weighting method.  
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Figure 4-9. Form to set up directional interpolation. 

To set up the directional interpolation task: 
1. In the Tools menu, click Directional Interpolation. A form will appear 

(Figure 4-9). 

5. Click the in the line for Channel Center Line File and select a GIS 
polyline Shapefile (*.shp) as channel center line. Survey points will be 
projected into the channel center line to calculate the streamwise and 
transversal coordinates. 

6. Click the in the line for Survey Point File and select a GIS point 
Shapefile (*.shp) as original survey points. The survey points should 
include location (x and y) coordinates and an elevation (z) coordinate. 

7. Click the in the line for Interpolate Boundary File and select a GIS 
polygon Shapefile (*.shp). Only points inside the boundary will be used 
for interpolation. 

8. Input data for streamwise weighting ratio. A larger weighting ratio will put 
more effect in the streamwise distance. 

9. Input data for transverse weighting ratio. A larger weighting ratio will put 
more effect in the transverse distance. 
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10. Input data for search range. Only points in a search range will be used for 
interpolation. 

11. Input data for Output Resolution, which is the spacing between 
interpolated points in both streamwise and transverse directions. 

12. Click the yes button to perform the directional interpolation or the no 
button to cancel the action. Currently, the interpolated points are saved in 
file “output.dat”. 

4.8. Create GIS TIN from SRH2D Results 
A GIS triangulated irregular network (TIN) file can be created from SRH-2D 
output file in Tecplot format. Follow these steps to generate a TIN. 
 

1. In the Tools menu, select Create GIS TIN from SRH2D Results. A form 
will appear (Figure 4-10). 

 

 
Figure 4-10. form to create a TIN file. 

2. Click the open file button in the line for the Result File and select a 
SRH-2D result file in Tecplot format. 

3. Select the result zone in the selection box. 
4. Select the variable in the selection box. 
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5. Check/uncheck the Include Blanking button if you want to blank cells. If 
you do not want to blank any cell, go to step 7. 

6. To include value blanking, click the add button and select the variable, 
condition operator (< or >) and input the value for the value blanking. You 
can use more than one conditional statement for value blanking. In the 
example in Figure 4-10, cells with variable z>2000 or z<1000 will be 
trimmed from the final TIN surface. 

7. Click the open file button in the line for “Folder” and select a folder to 
save the TIN file. 

8. Input the TIN name in the Name textbox. 
9. Click the yes button to create the TIN file or the no button to cancel the 

action.
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5. Tutorials 
This tutorial is based on the Sacramento River. 
 

5.1. Tutorial One – Import GIS Files 
Tutorial one shows how to input GIS data such as shapefiles. Generally, the first 
task of mesh generation is to import GIS data.  
Step 1: Launch SRH-Mesh. The start page is shown in Figure 5-1. 

 
Figure 5-1. SRH-Mesh start page. 

Step 2: SRH-Mesh main page will show up after waiting for 10 seconds. You can 
also left-click in the start form to switch to SRH-Mesh main page to get the main 
page to pop up immediately (Figure 5-2). 
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Figure 5-2. SRH-Mesh main page. 

Step 3: Click GIS in the table of contents and click the add button  in the GIS 
Module toolbar to import GIS data to the project. For the tutorial case, navigate to 
the directory where the GIS resides (e.g., GIS Data\Sacramento_RM192) and 
select “RM192.tif” file to add the map to the project. Use the zoom buttons to 
check the map (Figure 5-3). 
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Figure 5-3. Input Image.  

Step 4: Click the box immediately to the left of the GIS menu item in the table of 
contents to see the GIS file names. The GIS file named “RM 192.tif” should show 
up. Check or uncheck the box before GIS or before “RM 192.tif” to show or hide 
all GIS files or each individual GIS file. 
Step 5: Select File\Save Project A and save the project as “tutorial01.shrp”. 
Step 6: Click the GIS Module in the table of contents and click the add button  
in the GIS Module toolbar to add the GIS shapefile to the project. Navigate to GIS 
file Data\Sacramento_RM192 and select the “boundary.shp” file to add the GIS 
polyline feature to the project. Use the zoom buttons to check the polyline (Figure 
5-4). 

 



SRH-Mesh 1.0 User’s Manual 
Tutorials 
 

72  

 
Figure 5-4. Input GIS polylines. 

Step 7: Click the box immediately to the left of the GIS menu item in the table of 
contents to see the GIS file names.  The GIS shapefile with name “boundary.shp” 
should be there. Check or uncheck the box immediately to the left of the GIS 
menu item in the table of contents GIS or immediately to the left of the GIS 
“boundary.shp” to show or hide all GIS shapefiles or each individual GIS 
shapefile. 
Step 8: Click menu File\Save Project and save the project as “tutorial01.shrp”. 
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5.2. Tutorial Two – Geometry Lines 
Tutorial Two shows how to create and edit geometry lines. 
It starts from the saved project in Tutorial One. We will transfer the GIS shapefile 
into SRH-Mesh mesh and digitize new lines as upstream and downstream 
boundaries, edit vertexes, and redistribute vertexes in all the lines.  
Step 1: Launch SRH-Mesh, open the file “tutorial01\tutorial01.srhp”, and save 
this file as “tutorial02\tutorial02.srhp”. 
Step 2: Click on the menu item GIS\GIS Shapefile to Geometry to transform the 
GIS Shapefile into geometry features in SRH-Mesh. The line is shown as green 
lines in Figure 5-5. Uncheck the GIS Module in the table of contents.  

 
Figure 5-5. SRH-Mesh mesh is shown as green lines. 
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Step 3: Make sure that you are in the Geometry Module (the icon for the 
Geometry Module will appear in the lower left corner ). If not, click the 
Geometry Module in the table of contents. 
Step 4: Click the Geometry Module menu and make sure that the Snap is On is 
checked and “snap distance = 20 pixels” (Section Error! Reference source not 
found.).  
Step 5: Click the add button  in the Geometry Module toolbar to add a line. The 
Sacramento River flows from north to south, so the downstream end is at the 
bottom of your screen and the left bank should on your right side. Click as close 
as possible on the downstream of the left bank and move to the right side and 
double click on a point on right floodplain. The end point should be at least  
20 pixels away from the downstream of the right bank and the new created line 
should be as perpendicular as possible to the two banks (Figure 5-6).  

 
Figure 5-6. New created line at downstream end 

Step 6. Follow Step 3 to create another line at the channel upstream end (Figure 
5-7).  

 



SRH-Mesh 1.0 User’s Manual 
Tutorials 

 

75 

 
Figure 5-7. New created line at upstream end. 

Step 7. Click the split button  in the Mesh Module toolbar to split the lines at 
intersections.  

Step 8. Click the edit button  in the Geometry Module toolbar, and the Edit 
toolbar will be shown on the right of the Geometry buttons. A copy of the 
Geometry lines will be displayed in blue. Select the lines outside of the polygon 
and click Delete in the Edit toolbar.  

Step 9. Click the edit button  in the Geometry Module toolbar to enter Edit 
mode again. Select the right bank, and perform the move, insert, and delete 
functions to make sure that the bank follows the GIS. Edit the left bank in the 
same way. Save and exit the Edit mode. 

Step 10. Click the edit button  in the Geometry Module toolbar to enter Edit 
mode again. Select the left and right banks and click Redistribute button in the 
Edit toolbar, a form will pop out. Set the Node Number as 50 nodes, click the yes 
button to close the Redistribute form.  
Step 11. Follow Step 10 and redistribute the upstream and downstream lines with 
ten nodes. Save and exit the Edit mode. 
Step 12: Select File\Save Project from the menu and save the project as 
“tutorial02.shrp”. 

5.3. Tutorial Three – Simple Mesh Generation 
Tutorial three shows how to generate a series of simple 2D meshes. It starts from 
the saved project in tutorial two.  
Step 1: Launch SRH-Mesh, open the file “tutorial02\tutorial02.srhp” and save as 
file “tutorial03\tutorial03.srhp”. You can uncheck the boxes before GIS and GIS 
in the table of contents to hide the boxes. 

Step 2: Make sure that you are in the Mesh Module . If not, click Mesh in the 
table of contents. 
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Step 3: Click the select-outside-lines button  and hold the Ctrl key to select all 
four sides (lines) for the mesh. Click triangle-mesh button , and you have your 
first triangle mesh (Figure 5-8). 

 
Figure 5-8. SRH-Mesh triangle mesh. 

Step 4: Click the select mesh button  and then click a point inside of the mesh 
to select the mesh. Click the quadrilateral mesh button , and you have your 
first quadrilateral mesh (Figure 5-9). 
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Figure 5-9. SRH-Mesh quadrilateral mesh. 

5.4. Tutorial Four – Multi-Zone Mesh 
Tutorial four shows how to create a mesh with more than one zone and to assign 
the bed materials for roughness. It starts from the saved project in tutorial three. 
We will create a triangle mesh along the sandbar and a quadrilateral mesh along 
the mean channel. Inside the triangle mesh, we will create some denser mesh 
along a vegetated area. 
Step 1: Launch SRH-Mesh, open the file “tutorial03\tutorial03.srhp”, and save the 
file as “tutorial04\tutorial04.srhp”.  
Step 2: Go to Geometry Module, click the add button  in the Geometry Module 
toolbar to add two lines: one along the channel near the point bar, one by the 
vegetation (Figure 5-10). 
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Figure 5-10. Added lines near the sand bar. 

Step 3. Click the split button  in the Geometry Module toolbar to split the lines 
at intersections. Go the Edit Mode to delete the line outside of the channel. 

Step 4. Click the edit button  in the Geometry Module toolbar, and the 
Merge/Split toolbar will be shown on the right of the Geometry Module toolbar. 
A copy of the mesh will be displayed in blue. Select the left bank and click Split 
at near the upstream and downstream of the point bar. Save and Exit Merge/Split 
toolbar. 

 
Figure 5-11. Split left bank. 
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Step 5. Click the edit line button  in the Geometry Module toolbar to select 
lines and redistribute all 7 lines represent the banks and sand bar to 50 nodes, and 
the vegetation line into 20 nodes. Save and Exit. 

Step 6: Go to mesh module.  Click the select outside lines button  in the Mesh 
Module toolbar and hold the Ctrl key to select all two sides (lines) for around the 
point bar. Click the select inside lines button and select the vegetation line. 
Click the triangle mesh button , and you have a triangle mesh for the point bar.  

Step 7: Click the select outside lines button  and hold the Ctrl key to select all 
bank lines and end lines for the channel. Click the quadrilateral mesh button , 
and you have your quadrilateral mesh for your channel (Figure 5-9). 
Step 8: Right-click the Mesh Module in the table of contents (or use Menu 
Mesh\Set Mesh Prop erty). click reset change the bed zone display. Rename bed 
zones to Channel, Point Bar, and Vegetation. You can also change the display of 
bed zones according to your interest. Click the yes button to save the settings. 

Step 9: Click the select mesh button  and then click a point inside the mesh for 
point bar to select the mesh. Click the set mesh roughness zone button . 
Change the bed material to 2, which is for a point bar. (Figure 5-12). 
 

 
Figure 5-12. Bed roughness for the point bar.  

Step 10: Click the select cell button  and then use your mouse to select the 
cells around the vegetation zone cells. Click to select one cell or click and drag to 
select all cells in the area. Press the Ctrl key and then make more selections. Click 
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the set cell roughness zone button , and change the bed material to 3, which is 
for vegetation zone. (Figure 5-13). 

 
Figure 5-13. Bed roughness for the vegetation zone.  

Step 11: Save the project. 

5.5. Tutorial Five – Boundary Condition Line 
Tutorial five shows how to create boundary condition lines. It starts from the 
saved project in tutorial four. We will create two boundary condition lines, one 
upstream and one downstream, as well as one monitoring line.  
Step 1: Launch SRH-Mesh, open the file “tutorial04\tutorial04.srhp”, and save the 
file as “tutorial04\tutorial04.srhp”.  
Step 2: Go to the Boundary Condition Line Module, click the add button  in the 
Boundary Condition Line Module toolbar, click the vertex at top left corner of the 
mesh, and double-click the vertex of the top right corner of the mesh. Give the BC 
Line the name “Upstream” when prompted (Figure 5-14). 
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Figure 5-14. Upstream boundary condition line. 

Step 3. Move the map to the downstream of the channel, click the add button  in 
the Boundary Condition Line Module  toolbar, click the vertex at bottom left 
corner of the mesh, and double-click the vertex of the bottom right corner of the 
mesh. Give the BC Line the name “Downstream” when prompted (Figure 5-15). 

 
Figure 5-15. Downstream boundary condition line. 

Step 4. Move the map to the downstream end of the point bar, click the add 
monitor line button  in the Boundary Condition Line Module toolbar, click the 
vertex at one side of the channel and double-click the vertex of the other side of 
the channel. Give the Monitoring Line the name “Monitor” when prompted 
(Figure 5-16).  
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Figure 5-16. Monitoring line.  

Step 5: Click the save button  to save mesh and boundary condition lines in 
“.srhm” format. 
Step 6: Save the project.
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Appendix A. Example SRH-Mesh Mesh File 
A.1. Header 
A SRH-Mesh mesh file (.srhm) starts with two lines of a header. For exam    ple: 

SRH-Mesh 
NAME "2D unstructure mesh" 

A.2. Vertex 
It is then followed by the vertex data, starting with number of vertexes and x, y, z 
coordinates for each vertex. For example: 

VERTEX 60 
6.5722720742E+006 2.3728513889E+006 0.0000000000E+000 
6.5718524273E+006 2.3738811341E+006 0.0000000000E+000 
6.5718153926E+006 2.3749636725E+006 0.0000000000E+000 
… 

In this example, a total of 60 vertexes are defined. The first vertex (ID=0) is 
located at x=6.5718153926E+006, y=2.3749636725E+006, and 
z=0.0000000000E+000. 

A.3. Cell 
Cell data starts with the first line that defines the number of cells, then one data 
line for a cell that contains the number of vertexes in the cell, vertex indexes of 
the cell, and then roughness index. Followed by the optional data for bed 
gradation zone index and initial boundary condition zone. For example: 

CELL 44 4 False False 
 4 0 13 14 1 0 
 4 1 14 15 2 0 
 4 2 15 16 3 0 
 4 3 16 17 4 0 
 4 4 17 18 5 0 
… 
 

In this example,  
CELL 44 4 False False:  

CELL: cell data set 
44: a total of 44 cells 
4: maximum number of vertexes in a cell. 
False: No bed gradation zone is defined. 
False: No initial boundary condition is defined 

4 0 13 14 1 0 
4: first number is the total number of vertexes in the cell.  
0 13 14 1: indexes of vertex ID in the cell with the total number 

defined by the first number (4).  
0: roughness zone of the cell.  

4 1 14 15 2 0 
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4: first number is the total number of vertexes in the cell.  
1 14 15 2: indexes of vertex ID in the cell with the total number 

defined by the first number (4).  
0: roughness zone of the cell.  

A.5. BC Line 
BC Line data starts with the first line that defines the number of BC Line lines. 
For each BC Line line, it starts with a line that defines the number of vertexes in 
the line, followed by vertex indexes for the line. For example: 

LINE 2 
LN 0 4 "upstream" 
 12 25 38 59  
LN 1 5 "downstream" 
 0 13 26 39 47  

In this example,  
LINE 2: Two BC Lines are defined. 
LN 0 4 "upstream": the first line (ID=0) has 4 vertexes with a name 
“upstream”. 
The line vertex indexes are listed as: 12 25 38 59  
LN 1 5 "downstream": the second line (ID=1) has 5 vertexes with a name 
“downstream”. 
The line vertex indexes are listed as: 0 13 26 39 47  
 

A.7. END      
END: End record. 

 

A.8. Example SRH-Mesh Mesh Data 
SRH-Mesh 
NAME "2D unstructure mesh" 
VERTEX 60 
6.5722720742E+006 2.3728513889E+006 0.0000000000E+000 
6.5718524273E+006 2.3738811341E+006 0.0000000000E+000 
6.5718153926E+006 2.3749636725E+006 0.0000000000E+000 
6.5723211193E+006 2.3759219856E+006 0.0000000000E+000 
6.5732639953E+006 2.3765119967E+006 0.0000000000E+000 
6.5742628380E+006 2.3769934185E+006 0.0000000000E+000 
6.5753466621E+006 2.3770603746E+006 0.0000000000E+000 
6.5764218148E+006 2.3772878135E+006 0.0000000000E+000 
6.5773521582E+006 2.3778666124E+006 0.0000000000E+000 
6.5777010730E+006 2.3788388872E+006 0.0000000000E+000 
6.5774232331E+006 2.3798993204E+006 0.0000000000E+000 
6.5771238758E+006 2.3808813903E+006 0.0000000000E+000 
6.5770019773E+006 2.3819711381E+006 0.0000000000E+000 
6.5723512560E+006 2.3728934073E+006 0.0000000000E+000 
6.5719377671E+006 2.3738845619E+006 0.0000000000E+000 
6.5719023621E+006 2.3749406125E+006 0.0000000000E+000 
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6.5724157415E+006 2.3758717256E+006 0.0000000000E+000 
6.5733666873E+006 2.3764150909E+006 0.0000000000E+000 
6.5743829470E+006 2.3767196363E+006 0.0000000000E+000 
6.5754737160E+006 2.3767160597E+006 0.0000000000E+000 
6.5765714023E+006 2.3769369272E+006 0.0000000000E+000 
6.5774794755E+006 2.3775061319E+006 0.0000000000E+000 
6.5778606466E+006 2.3785546002E+006 0.0000000000E+000 
6.5776820647E+006 2.3797008276E+006 0.0000000000E+000 
6.5773576126E+006 2.3807785763E+006 0.0000000000E+000 
6.5772198586E+006 2.3819734360E+006 0.0000000000E+000 
6.5724304377E+006 2.3729354257E+006 0.0000000000E+000 
6.5720231068E+006 2.3738879896E+006 0.0000000000E+000 
6.5719893315E+006 2.3749175525E+006 0.0000000000E+000 
6.5725103636E+006 2.3758214656E+006 0.0000000000E+000 
6.5734693792E+006 2.3763181850E+006 0.0000000000E+000 
6.5745030560E+006 2.3764458541E+006 0.0000000000E+000 
6.5756007699E+006 2.3763717447E+006 0.0000000000E+000 
6.5767209897E+006 2.3765860410E+006 0.0000000000E+000 
6.5776199898E+006 2.3771526544E+006 0.0000000000E+000 
6.5780301179E+006 2.3782755656E+006 0.0000000000E+000 
6.5779474948E+006 2.3795058363E+006 0.0000000000E+000 
6.5775946486E+006 2.3806775131E+006 0.0000000000E+000 
6.5774377398E+006 2.3819757339E+006 0.0000000000E+000 
6.5725096194E+006 2.3729774441E+006 0.0000000000E+000 
6.5721084466E+006 2.3738914175E+006 0.0000000000E+000 
6.5720763010E+006 2.3748944925E+006 0.0000000000E+000 
6.5726049858E+006 2.3757712057E+006 0.0000000000E+000 
6.5735720712E+006 2.3762212792E+006 0.0000000000E+000 
6.5746231650E+006 2.3761720720E+006 0.0000000000E+000 
6.5757278238E+006 2.3760274299E+006 0.0000000000E+000 
6.5768705772E+006 2.3762351548E+006 0.0000000000E+000 
6.5725888011E+006 2.3730194624E+006 0.0000000000E+000 
6.5721937863E+006 2.3738948452E+006 0.0000000000E+000 
6.5721632704E+006 2.3748714325E+006 0.0000000000E+000 
6.5726996080E+006 2.3757209457E+006 0.0000000000E+000 
6.5736747632E+006 2.3761243732E+006 0.0000000000E+000 
6.5747432740E+006 2.3758982897E+006 0.0000000000E+000 
6.5758548777E+006 2.3756831149E+006 0.0000000000E+000 
6.5770201647E+006 2.3758842685E+006 0.0000000000E+000 
6.5777605041E+006 2.3767991769E+006 0.0000000000E+000 
6.5781995892E+006 2.3779965310E+006 0.0000000000E+000 
6.5782129249E+006 2.3793108450E+006 0.0000000000E+000 
6.5778316846E+006 2.3805764498E+006 0.0000000000E+000 
6.5776556211E+006 2.3819780317E+006 0.0000000000E+000 
CELL 44 4 False False 
 4 0 13 14 1 0 
 4 1 14 15 2 0 
 4 2 15 16 3 0 
 4 3 16 17 4 0 
 4 4 17 18 5 0 
 4 5 18 19 6 0 
 4 6 19 20 7 0 
 4 7 20 21 8 0 
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A-4  

 4 8 21 22 9 0 
 4 9 22 23 10 0 
 4 10 23 24 11 0 
 4 11 24 25 12 0 
 4 13 26 27 14 0 
 4 14 27 28 15 0 
 4 15 28 29 16 0 
 4 16 29 30 17 0 
 4 17 30 31 18 0 
 4 18 31 32 19 0 
 4 19 32 33 20 0 
 4 20 33 34 21 0 
 4 21 34 35 22 0 
 4 22 35 36 23 0 
 4 23 36 37 24 0 
 4 24 37 38 25 0 
 4 26 39 40 27 0 
 4 27 40 41 28 0 
 4 28 41 42 29 0 
 4 29 42 43 30 0 
 4 30 43 44 31 0 
 4 31 44 45 32 0 
 4 32 45 46 33 0 
 3 33 46 34 0 
 4 39 47 48 40 0 
 4 40 48 49 41 0 
 4 41 49 50 42 0 
 4 42 50 51 43 0 
 4 43 51 52 44 0 
 4 44 52 53 45 0 
 4 45 53 54 46 0 
 4 46 54 55 34 0 
 4 34 55 56 35 0 
 4 35 56 57 36 0 
 4 36 57 58 37 0 
 4 37 58 59 38 0 
LINE 2 
LN 0 4 "upstream" 
 12 25 38 59  
LN 1 5 "downstream" 
 0 13 26 39 47  
END 
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