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Introduction 

The Land Atmosphere Water Simulator (LAWS) is a tool designed for the management 
of large-scale, multi-organizational water supply systems.  LAWS differs from other 
water management models in several significant ways.  

First, LAWS simulates daily, field-scale land, crop, and water management practices. It 
provides users with tools to simulate alternative methods for managing soil moisture on a 
daily basis during the irrigation season based on soil properties, crop type and growth 
stage.  This approach permits LAWS to compute evapotranspiration, soil water content, 
surface water ponding, runoff, canal and drain losses, return flows to rivers, and deep 
percolation to groundwater at level of spatial and temporal resolution not present in 
existing planning and operations models.  Although LAWS performs these calculations at 
the field scale, LAWS also provides users with ability to aggregate these results within 
larger user definable areas so that water budgets can be readily computed for arbitrary 
organizational regions.  

Second, LAWS does not solve any governing flow equations except continuity nor is it 
an optimization model. This approach allows LAWS to be very computationally efficient 
but it requires the LAWS user to provide key input data from other sources of 
information such field studies, remote sensing, GIS databases, physical process models, 
and expert judgment. Although LAWS provides users with multiple methods for 
allocating water supplies and making priority based delivery decisions, LAWS does not 
employ any mathematical methods to determine what is the "best" allocation of water. In 
contrast, LAWS provides users with a powerful graphical user interface (GUI) that 
allows users to readily change water allocation and delivery priorities, land and crop 
management practices, and infrastructure characteristics to compare the effects of 
alternative system configurations on reservoir water supplies.  

Third, LAWS has a native GIS capability built directly into the GUI. This GIS capability 
allows users to setup and analyze spatially accurate LAWS simulations across a span of 
scales ranging from large regional watersheds to sub-regions contained with individual 
fields.  LAWS also provides users with the capability to import imagery, maps, and GIS 
information developed with commercially available software packages. Furthermore, 
LAWS has been developed from the Corp of Engineers Water Management System 
(CWMS) software from which it has inherited a powerful suite of tools to examine model 
outputs including side by side comparisons of outputs from multiple alternative 
simulations and animations of spatial and temporal time series results.  
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System Manager 
LAWS captures both the spatial and hierarchical organization of a water supply system. 
In LAWS, the supply system is conceptualized as a series of nested spatial units that 
range in size from multi-regional watersheds to individual land units as small as fields. 
The largest scale land area is associated with a System Manger (SM).  In a LAWS 
simulation, there may be one or more SMs.  At the next smaller spatial scale, each Area 
Manager (AM) manages a particular region within the system.  Within these regions, 
there are one or more Delivery Managers (DM).  These DMs represent sub-regions 
within the AM region where water management is performed differently based on some 
unique characteristics of the land or the water supply associated with the sub-region.  At 
the smallest scale, an individual land unit is represented by a Land Manager (LM).  Each 
LM is located within a single DM sub-region.  In LAWS, the geospatial locations of 
major reservoirs, rivers, canals and drains are explicitly located through its GIS capability 
down to the AM-scale. Although simulated mathematically, smaller scale conveyance 
infrastructure at the DM- and LM-scales is not explicitly geospatially referenced.  The 
LAWS spatial organization is shown in Figure 1 below. 
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River 

Canal

Canal 

Drain

Drain

LAWS Spatial Organization

Reach capacity, losses, travel times

 
Figure 1. LAWS Spatial Organization 

  
 
The LAWS hierarchical organization represents the basic structure for managing requests 
for water supplies and making management decisions necessary for determining the 
amounts of water to be released from reservoirs as well as the amounts of supply to be 
provided by groundwater pumping and drain water reuse by individual Land Managers. 
The LAWS hierarchical organization is presented on Figure 2 below. 
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Figure 2.  LAWS Hierarchical Organization 

  
 
 
Each SM operates one of more reservoirs which may be located on different rivers 
systems within a regional watershed.  Each reservoir consists of one or more accounts 
each of which is associated with a specific AM. The volume of water in each AM 
account is determined by a user specified percentage of the conservation pool.  The 
amount of water in the conservation pool is reset on annual basis during the course of a 
multi-year simulation.  The LAWS user has the option to allow an AM account to receive 
additional supply during a simulation in order to determine how much additional supply 
would be necessary to meet their water requirements over the simulation period. 
  
At each daily time step, the SM can use either a sequential or balanced allocation method 
to determine how much water to release from each of the reservoirs it manages.  In a 
sequential allocation the highest ranking account associated with a particular AM is fully 
depleted before the next highest ranking account is utilized.  In a balanced allocation, 
water from each reservoir account associated with a particular AM is utilized 
simultaneously in a user specified proportion.  If an account is completely utilized before 
the simulation is complete, the balance allocation ratios are recomputed to reflect the 
relative weighting of the accounts that still have remaining water supplies. 
  
The total amount of the SM deliveries must be constrained by the available release 
capacity of the reservoir and the capacity of the downstream river channels to convey 
releases without causing flood damage.  Since LAWS is intended to work in conjunction 
with other water management models, the reservoir release capacity can be specified at 
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every time step.  This approach permits LAWS reservoir releases to be constrained by 
other in-stream flow requirements that are not explicitly modeled in a LAWS simulation. 
This capability is accomplished by specifying a LAWS reservoir release capacity as the 
maximum physical release capacity minus the non-consumptive use flows that are 
released for other in-stream flow or water quality requirements.  Typically, these 
regulatory releases would be simulated with another model and a daily time series of 
maximum reservoir release capacities would be computed for a LAWS simulation. 
  
In LAWS, SM reservoir releases are delivered to AMs through an explicitly modeled 
network of rivers, canals, and drains.  The hydraulic properties of these conveyance 
system features are represented explicitly at user defined reaches along the channels.  The 
LAWS user specifies a maximum flow capacity for each reach and can simulate 
accretions and depletions in these reaches with simple gain/loss factors.  The transit time 
for water flowing through reaches is also specified by the user. 
  
It is important to recognize that LAWS does not solve the governing equations of flow in 
open channels.  LAWS simulates flow hydraulics and surface-groundwater interactions 
by using user specified factors.  Consequently, the LAWS user must develop this 
information from field studies, simulations using hydrodynamic and groundwater models, 
or expert judgment.  This simplistic approach used throughout LAWS avoids the 
computational overhead and complex data requirements of numerical models.  However, 
since LAWS is a mass conservative model, it can be used to determine water budgets 
from the regional-scale all the way down to the field-scale.  Further, the simplicity of the 
approach permits the LAWS user to efficiently compare alternative land and water 
management practices, infrastructure characteristics and configurations as well as water 
delivery priorities explicitly established at each level of the multi-organizational 
hierarchy. 
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Area Manager 
A LAWS Area Manger is one of the four levels in the LAWS hierarchical organization. 
An AM represents an organizational unit that manages of water supplies for a particular 
spatial region within the water supply system.    In the LAWS hierarchy, an AM is the 
intermediary between a System Manager (SM) and the Delivery Managers (DM) which 
supplies water to individual Land Managers (LM). 
  
The AM manages one or more water accounts.  Each of these accounts is associated with 
a particular SM and has a specified maximum volume.  An AM may have accounts with 
multiple SMs and more than one account with the same SM.  The AM is responsible for 
managing the use of its accounts during a simulation.  There are two account utilization 
mechanisms in LAWS.  In a sequential utilization operation, the highest priority account 
is used completely before water from the next highest priority account is delivered from 
reservoir storage.  In a balanced utilization operation, water from each account is utilized 
simultaneously in a user specified proportion.  If an account is completely utilized before 
the simulation is complete, the balanced utilization ratios are recomputed to reflect the 
relative weighting of the accounts that still have remaining water supplies. 
  
Although the SM determines the actual daily amounts of water released from an AM 
reservoir account, the AM is responsible for establishing the amounts of the groundwater 
pumping and drain water reuse to be used to meet consumptive use requirements within 
its DM sub-regions.  In LAWS, the total volume of ground water use is not absolutely 
constrained to a specified amount.  However, the amount of drain water recycling is 
limited to a user specified fraction of the total drain water inflow during each time step. 
These user specified factors represent the percentage of the total consumptive use 
requirement that is to be met from these sources of supply.  The groundwater pumping 
and drain water reuse factors are set by the user for each DM in the AM region at each 
time step.  In the event that the amount of drain water available for recycling is not 
sufficient to meet the AM target, groundwater pumping is automatically increased to 
make up for the deficit.  Since the groundwater pumping and recycling factors may be set 
to zero by the user, alternative simulations using only reservoir supplies may be readily 
performed for comparison with various pumping and drain water recycling alternatives. 
  
The AM is responsible for establishing the water delivery priorities that are to be 
implemented within its region.  LAWS employs a user specified hierarchical system to 
determine how water is delivered to individual LM within a DM sub-region.  The 
application delivery logic is designed to be user extensible so that multiple factors such as 
seniority of water rights, types of crop, growth stage, moisture stress or other user defined 
criteria could be employed in the delivery decision logic in future versions of the model. 
  
  
The AM is responsible for managing the DMs within its region.  At each time step, the 
AM must determine how much water to supply to each of its DMs.  After receiving 
deliveries for each of its accounts from one or more SMs, the AM may use one of three 
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different delivery priority mechanisms.  In a sequential delivery operation, each DM is 
given a fixed priority relative to the others in the AM region and the highest priority 
DM’s consumptive use requirement is completely satisfied before water from the next 
highest priority DM is delivered.  In a balanced delivery operation, delivery is made to 
each DM in a user specified proportion.  In hierarchical delivery operation, deliveries are 
to each DM based on the priority of individual LMs within the DM.  This mechanism 
essentially treats all DMs with equal priority but insures that LMs meeting the highest 
ranking in the highest hierarchical level are completely satisfied before lower priority 
water deliveries are made.  If a ranking is reached for which the remaining water supply 
is inadequate, a shortage delivery is made to the LMs in this ranking group. 
  
At each daily time step, the AM is responsible for receiving and accumulating the 
requests for water supplies from each of its DMs.  Using this request information, the 
AM employs its account utilization methods to determine how much water to request 
from its various accounts.  The amounts of requests are adjusted to account for 
conveyance depletions/accretions and forwarded to the SMs associated with each of its 
accounts. 
 

 
 

 
 
 
 

 
 
 

  10



   
   

Delivery Manager 
Within the overall structure of LAWS, the Deliver Manager serves as an intermediary 
between the Land Manager (LM) whose function is to apply water to an individual land 
unit and the Area Manager (AM) that requests and distributes water received from the 
System Manager (SM).  Each DM is associated with a single AM and operates to meet 
requests for water from multiple LMs. 
  
At each time step, the DM is responsible for accumulating the amounts of water 
requested by each of its LMs.  After all the LMs’ application requests have been 
received, the DM has the responsibility for determining an appropriate amount of water 
to request from its AM to meet the needs of all the land units within its sub-region. 
  
In order to determine the amount to request, the DM takes into account a number of 
physical and management factors impacting water use within its sub-region.  The 
physical factors include conveyance losses from canals, inflows and outflows associated 
with adjacent DM sub-regions, deep percolation to groundwater, as well as various 
inflows and outflows from drains.  Management factors include the desired amount of 
groundwater pumping and drain water reuse within the DM’s sub-region. The water 
budget components of the DM system are shown on the Figure 3 below. 
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Figure 3 Delivery Manager Water Budget Components 
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It is important to recognize that the canals and drains within a DM sub-region are not 
explicitly represented as physical features within a LAWS model.  The DM canals and 
drains represent the affect of field scale canals and drains on the overall water budget 
within the sub-region.  This approach allows simulation of a sub-region’s water balance 
without the difficult and time consuming task of explicitly accounting for all field-scale 
infrastructure typically found in a water delivery system.  At the same time, this approach 
allows users ample flexibility to investigate the important effects these features exert on 
the amount the water needed to meet consumptive use requirements. 
  
During each time step, the three major functions of a DM are to deliver to the LMs the 
water received from the AM, receive water application requests from LMs and determine 
an appropriate amount of water to request from the AM in the next time step.  It is 
important to recognize that the actual amounts of water received from the AM for 
delivery to the LMs may be less than the amount requested.   
 
At each time step, the AM establishes the deliver priorities within its region and notifies 
each DM of the supply available for delivery.  The total amount consists of reservoir 
releases, groundwater pumping, and recycled drain water.  Using the delivery priorities 
established by the AM, the DM delivers water to all the LMs for which sufficient supply 
is available.  
  
As the DM delivers water, LMs inform the DM of any unmet water needs by making an 
application request for whatever amount is still required for consumptive use based on 
the final soil water content after delivery to the land unit.  Once all the possible deliveries 
have been made, the DM queries the remaining LMs to determine their application 
requests.  This process insures that every land unit is queried and results in the soil water 
content and other water budget components of every land unit being updated at every 
time step. 
  
After the DM has completed the delivery process, the total amount of all LM application 
requests is known.  The DM must now determine the total amount of water to request 
(DIV) for the entire sub-region.  This process involves accounting for gains, losses and 
reuse of water within the sub-region.  In addition to water supplied by the AM, other 
sources of supply to the DM sub-region include inflows into canals from adjacent sub-
regions (IOR) and groundwater pumping (GWP).  Other than consumptive use of applied 
water (CUAW), losses from the sub-region include canal seepage (CLS), drain seepage 
(DLS), and deep percolation (DP) to groundwater, evaporation from canals (CLA) and 
drains (DLA) to the atmosphere, outflows from drains to adjacent sub-regions (DOR) and 
return flow from DM drains to AM drains (DRTN).  Tail water losses (TWL) and drain 
water reuse (DWR) within the DM’s sub-region are other user defined management 
factors that affect the amount of water the DM requests from the AM. 
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Land Manager 
 
The purpose of this design document is to outline the procedure and functions involved in 
the application of water to land units.  These land units are the fundamental spatial units 
included in the LAWS model.  In general, it is anticipated that these land units are 
agricultural fields, wetlands, or urban areas on which water is used consumptively. 
 
Within the overall structure of LAWS, the role of the Land Manager (LM) is to apply 
water received from the Delivery Manager (DM) to the land, determine the soil moisture 
content after application and request an appropriate amount of water from the DM 
depending on the status of the soil water content relative to particular management targets 
in effect at various times during the year. 
 
In order to provide flexibility for managing vegetation, the annual cycle is divided into 5 
vegetation stages.  These stages include: pre-germination (pg), rapid growth (rg), 
maturation (m), harvest (h), and post-harvest (ph).  The starting and ending dates for each 
of these periods can be specified by starting and ending dates during the calendar year.  
The evapotranspiration of the crop (ETC) is computed using user specified reference 
evapotranspiration and a crop coefficient as shown on Figure 4 below during each of the 
crop growth stages. 
 
 

kc 
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0 365 th tn t0 tm 

ETa = A(h) * kc * ET0 

Pre-Growth 
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Harvest 

Post-harvest 
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Figure 4 LAWS Evapotranspiration Model 

 
A(h) is a water stress function and is shown in Figure 5. 
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Figure 5  Water stress function. 

 
 
 
The root zone depth model employed in LAWS is shown on Figure 6. 
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Figure 6 LAWS root zone depth model 
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A user specified soil water content that triggers a water application request is associated 
with each of the management periods.  A request for water is generated when the root 
zone soil water content falls below the management Allowable Depletion (MAD).  The 
soil moisture management model is shown on Figure 7. 
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Figure 7 LAWS Soil moisture management model. 
 
The amount of water requested is determined by the root zone storage capacity at the 
time the request is made and the application efficiency of the system used to apply the 
water to the land unit.  The soil water capacity and hydraulic properties used by LAWS 
are presented on Figure 8. 
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Figure 8 LAWS soil water capacity and hydraulic properties. 

 
 
Since certain crops and management practices require ponding of water on the soil 
surface, a provision is made to manage water under both ponded and unponded 
conditions.  Components of the LAWS water budget with and without ponding are shown 
on Figure 9 and 10 respectively. 
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Figure 9 LAWS water budget components under ponding 
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Figure 10 LAWS water budget components without ponding. 

 
 
The following outline lays out the main calculations performed by the Land Manager. 
  
Non-ponded conditions 
 
The root zone mass balance is calculated using the following equation: 
 

)(/)}(){()1()( tRDRZSTWLETaRFGWPCDFtt ++−+++−= θθ  
 
where: 
 θ(t)  = water content of root zone at time t; 
 CDF = canal delivery (L); 
 GWP = applied groundwater (L); 
 RF = rainfall (L); 
 ETa = crop evapotranspiration (L); 
 TWL = tail water loss (L); 
 RZS = root zone seepage (L); 

RD(t) = root zone depth(L). 
 
The canal delivery is determined during previous time steps by considering the difference 
between the Soil Water Delivery Target set in the Irrigation System Type Editor and the 
Management Allowable Depletion (MAD) set in the Crop Type Editor. This volume is 
then increased by taking into account the application efficiency set in the Irrigation 
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System Type Editor.  This volume is then adjusted by the Demand Manager to account 
for the availability of groundwater and drain water recycling. 
 
During the current timestep, the total application of canal delivery water and groundwater 
is multiplied by the tailwater loss factor set in the Irrigation Systems Type Editor to 
calculate the tailwater water loss.  Rainfall generates no runoff.  ETa is calculated as 
described above.  Root zone seepage is calculated at the end of the timestep as the 
difference between the soil moisture content in the root zone and field capacity. 
 
Ponded conditions 
 
A land manager can become ponded if the sum of canal deliveries, groundwater 
pumping, and rainfall is in excess of the available soil moisture storage (ASMS) which is 
calculated as: 
 
ASMS =  (θs -  θ(t-1))RD(t)  
 
 where: 
 θs = soil moisture content at saturation. 
 
This situation will occur if there is a rainfall event that is in excess of the ASMS or if the 
ponding depth set in the Crop Type Editor is non-zero.  In this case, the ponded water 
depth (Pd) is calculated as: 
 
Pd(t) = Pd(t-1) + (CDL+GWP+RF) – (ETa + SWRO + PWI) 
 
where: 
 
 Pd(t) = depth of surface ponding at time t (L); 
 SWRO = surface water runoff from ponding (L); 
 PWI = pond water infiltration (L). 
 
SWRO is calculated as the product of the ponded water depth (DSP) and the Surface 
Water Runoff Factor located in the Land Manager Editor.  Root zone infiltration (RZI) is 
calculated using the Darcy Equation assuming that the soil beneath the root zone is at 
field capacity: 
 

)(
_)()(

tRD
FCPHtRDtPdKsRZI −+

=  (1 day) 

 
where: 
  
 Ks = saturated hydraulic conductivity (L/T); 
 PH_FC = pressure head at field capacity (L); 
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Since the root zone is considered to be saturated it is assumed that all RZI becomes root 
zone seepage (RZS). 
 
Drainage and Deep Percolation 
 
Subsurface drainage is calculated as the product of the root zone seepage and the Drain 
Inflow Factor specified in the Land Manager Editor.  Deep percolation is the remainder 
of the root zone seepage. 
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LAWS V1.5 Training  Exercise 1 

Exercise 1 – Creating a New Project and 
Stream Alignment  
 

Introduction 
 
Exercise 1 will start you on the process of becoming familiar with using the LAWS 
application.  This exercise demonstrates the initial setup of a LAWS project by 
familiarizing you with the process of adding maps and creating stream alignments.   
 
In this exercise, you will gain experience by using a simple fictitious area named 
Deltaville. 
 

 
            Figure 1.1 - Deltaville Agricultural Region 

 
 

Task Description 
 
The goal of this first exercise is to create a LAWS Project that contains a map and a 
simple stream alignment with one tributary.  Although subsequent exercises will contain 
a more detailed stream alignment, this exercise will only have a simple two segmented 
stream alignment.  This will help get you used to the stream tools and become 
comfortable when creating more detailed streams in the future.  The stream alignment 
will represent the main stem of a river (Sandy River) and one tributary, Farmer Creek.  A 
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LAWS V1.5 Training  Exercise 1 

watershed background map of the Deltaville region is provided on the LAWS install 
directory, under the following subdirectory Wokshops/Exercise1/maps.   
 
 
 

Getting Started 
 
The first step in starting the process of using LAWS is to create a new Project. 
   

• Launch LAWS by double-clicking on the LAWS icon on your PC's desktop. 
 
• Select New… from the File menu.   

 
• In the New… dialog select Project from the list and click Next.   

 
 
The New Project dialog will display as the one pictured below.   
 
 

 
Figure 1.2 - New Project Dialog 
 
  

• Give the project the Name "Project1" and a Description.   
 
• Select a directory you would like the project to reside in by clicking the ellipse 

button  within the Directory text field. 
 
• Last, click the Finish button.  
  

A Project directory is created using the given name.  All Project related files and 
directories reside under this main Project directory.   
 
The Project's node will appear at the top of a Project Tree in the Project Tree Pane.  The 
tree will also fill with data nodes and open an empty Map Schematic window. 
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LAWS V1.5 Training  Exercise 1 

Note: You may need to move the Content Pane down in order to see the full Project 
Tree in the Project Tree Pane.  To reposition the Content Pane, move the mouse 
pointer onto the border between the two panes.  The pointer will display as a double 
arrow (↔).  Then click and hold down the left mouse key.  Drag the edge down.    
 
 
 

Adding A Map Layer 
 
Maps are imported into the Project by adding them via the Map context menu.   
 

• Right-click on the Map node in the Project Tree and select Add Map.   
 

 
 
• Using the File Browser, browse to the LAWS install directory subfolder 

LAWS/Workshop/Exercise1/maps and select the basemap.img file.  
 

• Select the Create Copy check box located on the right side of the dialog to copy 
the map files to the Project’s directory and click OK.   

 
TIP: Selecting Create Copy in the Map Browser will create a Map directory in the 
Project's directory and copy the map file(s) to the directory.  If the option is not checked, 
the map's path will be hard coded to the directory where they reside.  If you move the 
Project to another location, the project may not be able to find the maps. 

 
 

 

 

          Figure 1.3 - Map Browser Dialog 
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LAWS V1.5 Training  Exercise 1 

The Map Schematic window will expand by default to show the total map extent.  

he following is a list of supported map types: 

DLG (USGS Digital Line Graphs) 

hange Format) 

grid) 

he Stream Alignment is a visual representation of the modeled stream system.  With or 

• Right-click the Stream Alignment node in the Project Tree and select New... from 

However, the map extent can be changed manually through the Default Map Properties 
editor, which is accessed under the Projects -> Default Map Properties menu.  For 
more detailed information on this editor, use the LAWS online Help system.  To view the 
Help System, select the Help -> Help menu.  Look under the Interface , Additional 
Tools section. 
 
T
 

SHP (ArcView shapefiles) 
DXF (AutoCAD Digital Exc
DEM (USGS Digital Elevation Models) 
IMG (Raster Image) 
ASC (ArcInfo ASCII 
NET (ASCII NetTIN) 
 
 

Creating a Stream Alignment 
 
T
without a map, a Stream Alignment will need to be created or imported.   
 

the popup menu.  
 

 
 

• In the New Stream Alignment dialog, enter the Name "Deltaville SA" and a 

• Stream Alignment Tools will be added to the current Map Schematic.  A new 

Description then click OK.  
 

Stream Alignment node   with the label "Deltaville SA" will appear under the 
main Stream Alignment node. 
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LAWS V1.5 Training  Exercise 1 

 
                     Figure 1.4 - Deltaville Sandy River 
 
TIP: If a Map Schematic is not opened, the creation of the stream alignment will open 
one automatically.   
 
Note:  The newly created Stream Alignment name is displayed in the Project Tree in 
bold type.  This indicates that the stream alignment is currently displayed in the active 
Map Schematic window.  Also notice there is an asterisk ( * ) next to the new Stream 
Alignment node.  This asterisk is there to indicate that the new node's data has not yet 
been saved to disk.  The asterisk also appears if any changes where made to the nodes 
data.  It is good practice to save the project after adding new items or if any significant 
changes have been made to the project.  To save the project, simply click the Save All  
icon on the menu bar.  
 

 
Drawing the Stream Alignment 
 

• Select the Stream Alignment Tool    from the tool bar along the left side of 
the Map Schematic.  
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Figure 1.5 - Sandy River Stream  

 
• Using Figure 1.5 as a guide, draw the Sandy River stream alignment.  The stream 

alignment must be drawn from upstream to downstream.  In our exercise, the 
upstream area is at the top right-hand corner of the map.   

 
• Hold down the Ctrl key and click with the left mouse button to place the first 

point of the main stream.  This will “drop” the first point (vertex) of the stream 
alignment and the cursor will change to a crosshair. 

 
• Continue to hold down the CTRL key and, using the mouse/cursor, progress from 

upstream to downstream and clicking at each succeeding point to draw the 
alignment. 

 
TIP:  Don't worry about following the stream image exactly.  We'll show you how to 
edit the stream alignment drawing in section 6 of this exercise. 

 
• To terminate the stream element, release the Ctrl key and click to place the last 

point of the stream.   A dialog will appear asking for the Name and Description.   
 
• Name the Stream Alignment "Sandy River", then click OK.  The name will 

display along the stream alignment in the map schematic. 
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Adding a Tributary 
 

Now let's add the Farmer Creek tributary to our Sandy River stream alignment. 
 

• Using  Figure 1.6 as a guide, start adding the Farmer Creek tributary by holding 
down the Ctrl key and clicking the upstream location. 

 

 

Farmer Creek 

             Figure 1.6 - Farmer Creek Before Creating Stream Alignment 
  

• Continue to hold down the Ctrl key and, using the mouse/cursor, progress from 
upstream to downstream and clicking at each succeeding point to draw the 
alignment. 

 
• To terminate the stream element, release the Ctrl key and click to place the last 

point of the stream.  
 

 
 
• The name request dialog will appear.  Name the stream "Farmer Creek" and click 

OK.   
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• Next, a dialog will appear asking if you would like to connect the tributary to the 
stream alignment Sandy River.  Click Yes.  The stream will turn orange on the 
Map Schematic. 

 

Editing the Stream Alignment 
 
Practice editing the stream alignment.  Refine your first stream so that it more closely 
follows the BaseMap image. 
 
First, use the Zoom Tool to get a closer view of the stream. 
 

• In the Map Schematic, select the Zoom Tool  .  Click and hold down the left 
mouse button.  Drag the mouse cursor down and to the right.  You will see the 
outline of a rectangle appear.  Enclose the area you would like to enlarge inside 
this rectangle.   To zoom out, right-click inside the Map Schematic. 

 
• Once you have the desired area of the stream within the rectangle, let go of the 

mouse key.  The mage within the rectangle will enlarged.   
 

• To start editing the stream, first select the Stream Alignment Tool  .  Then 
double-click on the stream.  The stream will turn red with blue points along it. 

 

 
                                       Figure 1.7 - Selected Stream Alignment 

 
• To move the blue points, select one with the mouse and hold down the left mouse 

key.  Move the point to a new location and then release the mouse key to place the 
point.  The stream will redraw to the new point location.     

 
• To add points, hold down both the Ctrl and Alt keys and left-click on the red 

stream alignment.  A blue point will appear. 
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• To delete extra points on the stream alignment left-click on the point while 

holding down the Ctrl and Shift keys.   
 

 
      Figure 1.8 - Configured Stream Alignment  

 
• Zoom out by selecting the Zoom Tool and Right-clicking in the Map Schematic. 
 
• Practice editing in a few other locations until you are comfortable with the 

process. 
 
 
Save the Project and Exit LAWS 
 

• Save the Project by selecting Save Project in the File menu.  
 

• Exit LAWS from the File menu.
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Exercise 2 – Global Data 

Introduction 

 
Exercise 2 introduces the Global Data portion of a LAWS project.  Global Data 
represents the base data that will be used later to create LAWS simulations.  These data 
are divided into four categories.   

 
o Crop Types 
o Irrigation System Types 
o Soil Types 
o Crop Schedules 

 
A LAWS project is provided in the LAWS install directory under the subdirectory 
LAWS/Workshop/Exercise2.  In this exercise, you will gain experience by using a simple 
fictitious area named Deltaville. 

 

 
               Figure 2.1 - Deltaville Agricultural Region 
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Task Description 
 
The goal of this exercise is to create four Global Data sets for the Deltaville LAWS 
Project using the information provided on irrigation systems, soil types, crop types, and 
crop schedules.  This information will be used in later exercises to create other parts of 
the LAWS project.  Although subsequent exercises will contain more Global Data, 
Exercise 2 will only have a few simple examples to get you familiar with the software.   
 
 
 

Getting Started 
 
   

• Launch LAWS 
 
• Select Open Project from the File menu.   

 
• Browse to the location of this exercise's project using the File Browser.  The 

project is located in the LAWS install directory under the following: 
LAWS/Workshop/Exercise2/Exercise2.prj file. 

 
• Then click Open.   

 
The Exercise 2 project will load into LAWS.  
 

 
                               Figure 2.2 - Deltaville Exercise 2 
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• Open the Sandy River Stream Alignment in the current Map Schematic by right-
clicking on the Sandy River node label in the Project Tree and select Open from 
the popup menu.   

 

 
  

The Sandy River stream alignment will draw in the current Map Schematic. 
 
 
 
 

Adding Crop Types 
 
Crop Types indicate the choices of agricultural crops that will be available for modeling 
in the Project.  Each Crop Type contains information on the plant's type, life cycle, 
growth stage, and planting dates.  Two Crop Types have already been created, Wheat and 
Corn.  In this exercise, we will be adding Tomatoes.   
 

• Open the Crop Type Editor by right-clicking on the Crop Type node in the 
Project Tree and selecting Edit.   

 

 
 

TIP: You can also activate the editor by double-clicking on the Crop Type node in 
the Project Tree. 
 
NOTE: To view existing Crop Types, use the navigation buttons to the right of the 
current Crop Type name.  The Navigation buttons include: First Record , Previous 
Record , Next Record , and Last Record .  The Crop Types can also be 
selected using the Name combo box list.  All editors in LAWS use this navigation to 
view previously created items. 
 
• The Crop Type Editor will open. 
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                     Figure 2.3 - Crop Type Editor 

 
TIP: Use the Help menu in the editor to learn more about the Crop Type Editor 
 

• To create the new Crop Type, select CropType -> New from the menu bar in the 
editor. 

 
• The New Crop Type dialog will appear.  Give the Crop Type the Name 

"Tomatoes" and a Description.  
 

• Using the values displayed below in Figure 2.4, fill in the information on Alfalfa. 
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    Figure 2.4 - Crop Type Editor 
 
 
NOTE: SWMT is the Soil Water Management Target.  Please use the online Help to 
understand the values used in the Editor. 

 
• When you are finished entering information into the editor, click OK to save 

the new Crop Type and close the editor. 
 
• Save the new Crop Type to the Project files.  Right-click on the Crop Type 

node in the Project Tree and select Save form the popup menu. 
 
 

NOTE: Additional information on Crop coefficient data can be obtained from the 
following references: 

 
o On the Web at 

http://biomet.ucdavis.edu/evapotranspiration/CropCoef/crop_coefficients.
htm 

 
o Reference Book 

Crop evapotranspiration - Guidelines for computing crop water 
requirements - FAO Irrigation and drainage  
By Richard G Allen, Luis S. Pereira, Dirk Raes, Martin Smith 
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FAO - Food and Agriculture Organization of the United Nations 
Rome, 1998 
Available on the Web at: 
http://www.fao.org/docrep/X0490E/X0490E00.htm 
 
 

Adding Irrigation System Types 
 
Irrigation System Types represent the different irrigation methods used to provide water 
to the crops.  Examples of Irrigation System Types include Drip Line, Sprinkler, etc.   
 

• Double-click the Irrigation System Types node in the Project Tree. 
 
TIP: You can also activate the editor by right-clicking the Irrigation System Types 
node and selecting Edit from the popup menu. 
 

• The Irrigation System Types Editor will display as below. 
 

 
                       Figure 2.5 - Irrigation System Type Editor 

 
TIP: Use the Help menu in the editor to learn more about the Irrigation System Types 
Editor. 

 
• There are four default Irrigation types already populating the editor.  We need a 

more specific type of sprinkler, a center pivot, added to our project.   
 
• Each row in the table represents a different system.  To add the Center Pivot, click 

on the bottom row's first cell in the table and type "Center Pivot".   
 
• The Efficiency value for the Center Pivot is ".90".  The Tailwater Loss Fraction 

is "0.0".  And the SWDT (Soil Water Delivery Target) is "1.0".  
 

• Click OK to save the changes and close the editor. 
 

TIP:  Notice there is an asterisk ( * ) next to the Crop Type and Irrigation System Type 
nodes.  This asterisk is there to indicate that changes have been made to the nodes data 
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and that these changes have not been saved to disk.  In our case, new data has been 
created.  It is good practice to save the project after significant changes have been made 
to the project.   
 

• Save the project by clicking on the Save All icon  on the main toolbar.  

 

Adding Soil Types 
 
Soil Types represent the various soils that can be modeled.   
 

• Double-click on the Soil Type node in the Project Tree.   
 
• The Soil Type Editor dialog will appear as the one pictured below. 
 

 
                                  Figure 2.6 - Soil Type Editor 

 
TIP: Use the Help menu in the editor to learn more about the Soil Types Editor. 
 

• In the Soil Types Editor, create a new Soil Type by selecting Soil Type -> 
New... 

 
• Give the new Soil Type the Name "DeltavilleClay" and a Description, then 

click OK. 
 
• In the editor, enter the following values: 

o Sand Content 20% 
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o Silt Content 20% 
o Clay Content 60% 
 

NOTE: The total percent must equal 100 before the calculation can be preformed.  
 

• Once the percentages for the Sand, Silt, and Clay in are filled in, click on the 
Calculate button. 

 
Notice that the Van Genuchten Parameters now appear on the right-side of the editor.  
These values are used in modeling unsaturated flow in LAWS.  Also note that values for 
the Soil Water Content at various moisture levels and hydraulic conductivity at 
saturation are calculated. 

 
NOTE: For additional information on Soil Types see the following references: 

o Soil Texture Triangle on the Web: 
http://www.uwsp.edu/geo/faculty/ritter/glossary/s_u/soil_texture_trian

gle.html 
 
• When you are done adding the Soil Type, click OK to close the editor and 

save the information. 
 
• Save the project by clicking on the Save All icon  on the main toolbar.  
 

Adding Crop Schedules 
 
Crop Schedules indicate the agricultural rotations for the crops.  They include the year 
and date in which a particular Crop Type will be planted.  During a simulation, if the year 
indicated by the Crop Schedule is not included in the time range of the computations, 
then the Crop Schedule will automatically determine the appropriate initial crop and 
proceed to rotate the crops throughout the simulation.  However, the user should to 
determine whether the Crop Schedule is appropriate for their purposes. 
 

• Double-click the Crop Schedule Node in the Project Tree.  
 
• The Crop Schedule Editor dialog will appear as pictured below. 
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     Figure 2.7 - Crop Schedule Editor 

 
TIP: Use the Help menu in the editor to learn more about the Crop Schedule Editor. 

 
• To create a new Crop Schedule select Crop Schedule  -> New.... 
 
• On the New Crop Schedule dialog, enter the Name "Rotation1" and the 

Description "Corn, wheat, and tomato rotation." then click OK.   
 
• In the Crop Schedule Editor fill in the table with the following planting events, 

choosing from the Crop Types created earlier.   
 

o 1980  Corn 
o 1981 Wheat 
o 1982 Tomatoes 
 

NOTE: If the simulation were to continue into 1983, corn would be planted again, then 
Wheat in 1984 and Tomatoes in 1985. 

 
TIP: Crop Types editor is available through the Crop Schedule editor's menu Edit -> 
Crop Types. 

 
• The Plant Date and End of Harvest areas will fill automatically with the Early 

Planting and Harvest date for each event once the Year and Crop are entered.  
These dates were determined when the Crop Type was created.  For more 
information on this topic, see the section on Crop Schedules in the online Help.   

 
• When you are done, click the OK button. 

 
NOTE: The Content Pane, located just below the Project Tree Pane, displays the 
selected tree node's content.  For example, if the Crop Type node is selected in the 
Project Tree, each previously created Crop Type will be listed in the Content Pane.   
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Save the Project and Exit LAWS 
 

• Save the Project by selecting Save Project in the File menu.  
 

• Exit LAWS from the File menu. 
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Exercise 3 – Land Modules and Cropping 
Plans 
 

Introduction 
 
Exercise 3 introduces Land Modules and Cropping Plans.   
 
Land Modules can be added to the project by importing them from a shape file or 
manually creating them using the Land Manager Tool.  A Land Module represents a 
collection of Land Managers.  Land Managers represent individual parcels of land within 
the modeled area.  Land Managers display as polygons on the Map Schematic.   
 
Cropping Plans link the Land Managers to the Crop Types and Crop Schedules created in 
the Global Data. 

 
A LAWS project is provided in the LAWS install directory under the subdirectory 
LAWS/Workshop/Exercise3.  In this exercise, you will gain experience by using a simple 
fictitious area named Deltaville. 

 

 
   Figure 3.1 -Deltaville Agricultural Region 
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Task Description 
 
The goal of this exercise is to create multiple Land Managers for the Deltaville LAWS 
Project using the information provided.  You will become familiar with using the Land 
Manager Tool to create new Land Managers.  Although subsequent exercises will contain 
more Land Managers, Exercise 3 will only have a few simple examples to get you 
familiar with the software.   
 
 

Getting Started 
 
   

• Launch LAWS by double-clicking on the LAWS icon on your PC's desktop. 
 
• Select Open Project from the File menu.   

 
• Browse to the location of the LAWS install directory using the File Browser.  The 

project file will be under the following subfolder: 
 
LAWS/Workshop/Exercise3/Exercise3.prj file. 

 
• Then click Open.   

 
The Exercise3 project will load into LAWS.  
 

 
                             Figure 3.2 - Main Screen 
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• Open the Sandy River Stream Alignment in the current Map Schematic by right-

click on the Sandy River node label in the Project Tree and select Open from the 
popup menu.   

 

 
  

The Sandy River stream alignment will draw in the current Map Schematic. 
 
 

Importing a Land Module 
 

Land Modules are collections of Land Managers.  In our example, a Land Manager 
represents an individual agricultural field.  Most Land Modules will contain a large 
number of Land Managers.  Initially each Land Manager must be created manually.  The 
Land Manager information is saved to an Arc Shape file, <Land Module Name>.shp, 
which is automatically created.  You can also create such a file using GIS.  In our 
example, we will be using a previously created Land Module Arc Shape file to create our 
Land Module.  We will then manually add a Land Manager to it. 

 
• Right-click on the Land Module node and select Create Land Module from 

Shape File from the popup menu. 
 
• An Import Land Manager Wizard dialog will appear as the one pictured in 

Figure 3.2 below. 
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                    Figure 3.3 - Import Land Managers Wizard Step 1 

 
• Enter the Name "Base" and fill out the Description field. 
 
• Select the ellipse button  in the Shape File field and locate to the Base.shp file 

on the LAWS install directory under LAWS/Workshop/Exercise3/DataSheets. 
  
• Click Next 

 
• Step 2 of the wizard will display, pictured in Figure 3.3 below. 
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                    Figure 3.4 - Import Land Managers Wizard Step 2 

 
• Select the only option available in the Land Manager Name Attribute 

dropdown list. 
 
• Click Next 
 
• Step 3 appears.  We would like to draw one of the fields by hand, so uncheck  

LM14 from the listed fields (ID_NAME).  Then select Next.  
 
• After looking over the summary of the import in Step 4, select Finish. 
 
• A new Land Module node will appear under the Land Modules node in the 

Project Tree.  The Land Manager Tool   will be added to the toolbar on the 
current Map Schematic. 

 
•  We will use this tool to create a Land Manager on the map in the next step.   

 
 
 

Manually Creating a Land Manager 
 

• First select the Land Manager Tool     in the Map Schematic.  
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LM14 

 
 
 

 
• Use the Zoom Tool to zoom in on the location of the missing Land Manager, 

LM14. 
 
• Select the Land Manager Tool again.  While holding down the Ctrl key, left-

click in the Map Schematic window were you would like to place the first point.   
 
• While continuing to hold down the Ctrl key, outline of the field shape by left-

clicking points on the map. 
 

TIP: Be sure to create an enclosed area and not overlap the outline on itself.   
 
• For the final point, release the Ctrl key and click.   
 
• The outlined area will fill in with yellow, indicating it is selected, otherwise it will 

appear green.   
 
• To Zoom out, select the Zoom Tool.  Then, inside the Map Schematic window, 

click the right mouse button. 
 

• Save the changes you made by selecting Save Project in the File menu.  
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Editing the Land Managers 
 
The Land Managers now need to be assigned Soil and Irrigation System Types. 
 

• Select the Land Manager Tool. 
 
• Right click on a Land Manager in the Map Schematic and select Edit Land 

Manager from its popup menu.   
 
• The Land Manager Editor will appear with the selected field information 

displayed.   
 

 
                                     Figure 3.5 - Land Manager Editor 

 
TIP: Use the Help menu in the editor to learn more about the Land Manager Editor 
 

• Using the data below, fill out the information for LM1 and LM2 in the Land 
Manager Editor. 

 
o Land Manager LM1: 

 Land Use: Irrigated Field 
 Irrigation System Type: Portable 
 Ponding Water Runoff Factor: 0.1 
 Drain Inflow Factor: 0.2 
 Enter Soil By: Soil Type 
 Soil Type:  

• 70% DeltavilleSand  
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• 30% DeltavilleSilt 
• 0% DeltavilleClay 
 

• Once you are done enter data for LM1, click the Compute button. 
 

 
 

o Land Manager LM2: 
 Land Use: Irrigated Field 
 Irrigation System Type: Furrow 
 Ponding Water Runoff Factor: 0.3 
 Drain Inflow Factor: 0.2 
 Enter Soil By: Soil Properties 
 Specify Values, NeuroMultiStep Values 
 Soil Property Input Values:  

• Sand Content 60% 
• Silt Content 30% 
• Clay Content 10% 

 
• Again, when you are done enter data for LM2, click the Compute button. 

 
• Click OK to close and save the editor. 
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Editing Multiple Land Managers Simultaneously 
 
Multiple Land Mangers can be edited all at once.  Instead of entering this information 
repeatedly for each Land Manager at a time, you can enter it once for all of them.  In our 
example, we will enter data for Land Manager LM5 through LM16. 
 

• First be sure the Land Manager Tool  is selected.   
 
• To edit multiple Land Managers, hold down the Shift key and left-click on Land 

Managers LM5 through LM16.   
 
 

 
               Figure 3.6 - Multiple Land Managers Selected 
 
HINT: Multiple Land Managers can also be selected by circling them with the Land 
Manager tool.  Hold the mouse key down and draw a circle around the Land Managers 
you would like to edit, see below. 
 

 
         Figure 3.7- Selecting Multiple Land Managers by Circling Them 
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TIP: To see the name of the Land Manager, hover the cursor over the Land Manager 
until the name tooltip appears. 

   
• The Land Managers will turn yellow, indicating they are selected.   
 
• Once all the desired Land Managers are selected, right-click one to trigger the 

popup menu and select Edit Land Manager.   
 
• The Land Manager Editor will appear.   
  
• All selected Land Managers' names will be shown in the Land Manager Name 

text field.  Information entered in the editor will be applied to all selected Land 
Managers. 

 
• Use the values below to fill out the Land Managers' information. 

 
o Land Managers: 

 Land Use: Irrigated Field 
 Irrigation System Type: Drip 
 Ponding Water Runoff Factor: 0.0 
 Drain Inflow Factor: 0.1 
 Enter Soil By: Soil Type 
 Soil Type:  

• 60% DeltavilleSand  
• 20% DeltavilleSilt 
• 20% DeltavilleClay 

 
 
• When you are done enter the data, click the Calculate button. 
 
• Click OK to save and close the dialog. 
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Creating a Cropping Plan 
 
A Cropping Plan links the Land Managers to Crop Schedules.   
 

• Right-click on the Cropping Plan node and select New… from the popup menu. 
 
• The New Cropping Plan dialog appears. 
 
• Give the new Cropping Plan the Name "Simple Plan" and a Description, then 

click OK. 
 
• A Cropping Plan node will appear labeled with the new name. 
 
• Right-click on the new Simple Plan node and select Edit from the popup menu.  

The Cropping Plan Editor will appear. 
 
• Select a Crop Schedule for each Land Manager listed in the Cropping Plan 

Editor using Figure 3.7 below as a guide.   
 

 
                    Figure 3.1 - Cropping Plan Editor 

 
TIP: Use the Help menu in the editor to learn more about the Land Manager Editor 
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NOTE: The Crop Schedule "Rotation 1" was created in the previous exercise, Exercise 
2.     

 
• When you are finished, click OK to close and save the dialog. 

 
 
 

Save the Project and Exit LAWS 
 

• Save the Project by selecting Save Project in the File menu.  
 

• Exit LAWS from the File menu. 
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Exercise 4 – Flow Network and Atmospheric 
Modules 
 

Introduction 
 
Exercise 4 introduces the creation of Flow Networks and Atmospheric Modules.  Flow 
Networks represent the water storage and conveyance system simulated by the model.  
These resources include the following: 

 
o Reservoirs 
o Reaches 
o Junctions 
 

Using the data provided, you will learn how to create visual representations of reaches, a 
reservoir, and Met Stations.     
 
Atmospheric Modules hold collections of Met Stations.  A Met Station is used to indicate 
the location and area of influence of a meteorological station.  The Met Station's default 
display is a simple Icon on the Map Schematic.  The area of influence of a Met Station is 
specified by a radius or polygon. 
 
 
A LAWS project is provided in the LAWS install directory under the subdirectory 
LAWS/Workshop/Exercise4.  In this exercise, you will gain experience by using a simple 
fictitious area named Deltaville. 
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                               Figure 4.1 - Deltaville Agricultural Region  

 
 

Task Description 
The goal of this exercise is to become familiar with creating and editing Flow Networks 
and Met Stations.  You will become familiar with using the Reach, Reservoir, and Met 
Station tools to create new Flow Networks and Atmospheric Modules.   
 
 
  

Getting Started 
 

• Launch LAWS by double-clicking on the LAWS icon on your PC's desktop. 
 
• Select Open Project from the File menu.   

 
• Browse to the location of the Exercise 3 project using the File Browser.  The 

project file will be under the LAWS install directory in the following subfolder: 
LAWS/Workshop/Exercise4/Exercise4.prj file. 

 
• Then click Open.   

 
The Exercise 4 project will load into LAWS.  
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                 Figure 4. 2 - Project Exercise 4 
  

• Open the Sandy River Stream Alignment by right-clicking on the Sandy River 
node label in the Project Tree and selecting Open from the popup menu.   

 

 
  

The Sandy River stream alignment will draw in the current Map Schematic. 
 

• Open and load the Base Land Module by right-clicking on the Base node and 
selecting Open from the popup menu.   

 
The Land Managers will appear on the Map Schematic like those pictured above in 
Figure 4.2. 
 
 
Creating a Flow Network 
 
Flow Networks represent the rivers and conveyance infrastructure used to provide water 
to the fields.  They are represented visually on the Map Schematic as Reaches, 
Reservoirs, and Junctions.   
 

• Right-click the Flow Network Module node    in the Project Tree and select 
New... from the popup menu.   

 
• In the New dialog, enter a Name and Description for the new Flow Network. 
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• Select the Sandy River Stream Alignment for the Flow Network and click OK.  
 
• A new Flow Network Node  will be created under the Flow Network Module 

Node.  Flow Network tools will be added to the toolbar in the current Map 
Schematic. 

 

 
                Figure 4.3 - Land Managers 
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Creating a Reservoir 
 
 

 
         Figure 4.4 - Flow Network 

Farmer Creek 

 
Reservoirs must be drawn on the stream alignments within the Map Schematic.  
Using the Reservoir Tool, a reservoir can be created on top of the stream.  Use Figure 
4.4, above as a reference for placing the reservoir.  Do not worry about matching the 
picture exactly.  This exercise is to get you used to using the tools and not to mimic 
the picture.   

 

• Select the Reservoir Tool   in the Map Schematic.   
 
• While holding down the Ctrl key, left-click the Stream Alignment to select the 

upstream location of the reservoir on Farmer Creek. 
    
• Release the Ctrl key just before the confluence with Sandy River and left-click on 

the Stream Alignment to select the downstream/end location of the reservoir.   
 
HINT: Before left-clicking you will see a line connecting the point arrow to the last 
click placement.  This line is to indicate where the reservoir begins and is intended to 
help with its placement.  
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• The Name New Reservoir dialog will appear.  Give the new reservoir the Name 

"Farmers Reservoir" and click OK. 
• The reservoir's reach will fill in and a triangle will appear at the downstream 

location.   
 

TIP: This triangle is the Reservoir's pool.  This pool shape can be changed to reflect the 
actual shape of the reservoir's pool.  
 
 
Creating Reaches 
 
 

 
            Figure 4.5 Reaches 

 
Reaches represent the rivers, streams, canals, and channels within the flow network used 
by the model.  Like the reservoir, they must be drawn on the stream alignment by the 
user.  Use Figure 4.5 above as a reference for creating reaches for the Deltaville project.  
Do not worry about matching the project perfectly.    

 
• Use the Zoom Tool to zoom in on the location just below Farmer Reservoir.   
 

• Select the Reach Tool   in the Map Schematic. 
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• While holding down the Ctrl key, click the downstream location of Farmer 

Reservoir, where the Reach will begin on the Stream Alignment.  
 
• Release the Ctrl key and click on the Stream Alignment where Farmer Creek 

meets Sandy River. 
 
• The Name New Junction dialog will appear.  Accept the default name by 

clicking OK. 
 
• The Name New Reach dialog will appear.  Again, use the default name and click 

OK.  
 

TIP: Similar to the Reservoir placement, you will see a line connecting the point arrow to 
the last clicked spot on the stream.   

 
• The end points will become red Junctions  , unless the Reach was ended or 

started at a Junction.  In that case, the Reach will use the existing Junctions.  The 
area between the points, along the stream alignment, will fill with the new Reach.   

 
• Create another reach that goes from the top of Sandy River to the new Farmer 

Creek junction. 
 
• You can continue to create more reaches down the river. 
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Editing a Reservoir 

 
Reservoirs have physical data that need to be filled out through the editor.   
 

• Be sure the Reservoir Tool is selected, then right-click on the Reservoir in the 
current Map Schematic and select Edit Reservoir from the popup menu.  

 
HINT: You can also access the editor by right-clicking on the Flow Network's node and 
selecting Edit -> Reservoir from the popup menu. 

  

 
                                      Figure 4.6 - Reservoir Editor 

 
TIP: Use the Help menu in the editor to learn more about the Reservoir Editor 

 
• In the Reservoir Editor, enter 23,000 ac-ft for Maximum Conservation Storage 

and 0 cfs for the Instream Flow Requirement.   
 
• Choose Constant for the Release Capacity Option from the option's dropdown 

list.   
 
• Enter the 3,000 for the Maximum Release Capacity.   

 
• Click OK to save the changes and close the dialog. 
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Editing the Reaches 
 
Similar to reservoirs, reaches need to have physical data filled out through the editor.  In 
this exercise, we will only be filling in Reach data for one reach.   
 

• Be sure the Reach Tool  is selected, then right-click on the Reach in the 
current Map Schematic and select Edit Reach from the popup menu.  

 
HINT: You can also access the editor by right-clicking on the Flow Network's node and 
selecting Edit -> Reach from the popup menu. 

 

 
                              Figure 4.5 - Reach Editor 

 
TIP: Use the Help menu in the editor to learn more about the Reservoir Editor 

 
• The Reach Editor will appear.  Within this editor fill in 2 days for the Travel 

Time, 0.1 for the Channel Losses, and 3,000 cfs for the Channel Capacity. 
 
• When you are done, click OK to save and close the editor.   

• Save the project changes so far by clicking on the Save All icon  on the main 
toolbar. 

 
 
Creating an Atmospheric Module 
 
Atmospheric Modules hold collections of Met Stations.  Met Stations represent 
meteorological stations for a specified area.  This data includes reference ET and 
precipitation data. 
 

40 



LAWS V1.5 Training  Exercise 4 
   

• Right-click on the Atmospheric Modules node   in the Project Tree and select 
New... from the popup menu.   

 
• The New Atmospheric Module dialog appears.   
 
• Give the Module the Name "Simple" and a Description. 
 
• Click OK.    
 
• The new Atmospheric Module node  , with the given name, will appear under 

the Module's node.  
 

• A Met Station Tool   will be added to the current Map Schematic's Toolbar.   
  
 
Adding Met Stations to the Map Schematic 
 
 

 
                                          Figure 4.6 - Met Stations 
 
A Met Station is placed at the location where meteorological data is collected.  The Met 
Station's default display is a simple icon in the Map Schematic.  The Met Station has an 
area associated with it.  The area, by default, is not drawn on the Map Schematic.  It can 
be displayed to encircle the Met Station icon by a given radius or with a polygon shape.  
These shapes represent the area where the meteorological station data is used in the 
model.   
 

• Select the Met Station Tool  in the Map Schematic. 
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• Hold the Ctrl key down and click on the area you would like to place a Met 

Station.  Use Figure 4.7 above as a reference. 
 
• To display the actual area of influence for the Met Station you must select it on 

the Maps tab. 
 
• Select the Maps tab at the bottom left-hand side of the LAWS screen. 
• In the Map Layers tree, find the Atmospheric Modules name, Simple, and expand 

its tree node by selecting the plus + sign next to it. 
 
• You should be able to see two more tree nodes, Coverage Area and Icon.  Click 

the box next to the word Coverage Area. 
 

 
 
• A yellow circle will appear around the Met Stations in the Map Schematic.  The 

circle represents the area covered by the Met Station's data.   
 
• You can increase the area of the Met Stations by right clicking in the Map 

Schematic and selecting Edit Met Station from the popup menu. 
 
TIP: At least one Met Station needs to cover every Land Manager. 

 
• In the Met Station Editor, increase the value of the Radius (ft) and click Apply. 
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Change one of the area's shape to a Polygon.  
 
• Select the Met Station Tool. 
 
• Right-click on a Met Station and select Edit Met Station from the popup menu. 
 
• In the editor, select Polygon from Region Type dropdown list. 
 
• Click OK to save and close the editor. 

  
Now change the shape of the polygon.  
 

 
 
• Use the Zoom Tool to zoom in on the polygon in the Map Schematic. 
 
• Double-click on the polygon shape to set it active.  Notice that yellow points 

appear on the edges of the polygon shape. 
 
• To move a point, left-click on the point and hold down the mouse button.  Move 

the point to a new location and release the mouse button. 
 
• To add points, left click while holding down the Ctrl key. 
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• To remove a point, left-click on the point while holding down the Ctrl and Shift 

keys.  
 
 
Saving the Project and Exiting LAWS 
 

• Save the Project by selecting Save Project in the File menu.  
 

• Exit LAWS from the File menu. 
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Exercise 5 – Water Management Modules 
 

Introduction 
 
Exercise 5 introduces the creation of a Water Management Module.  This module is made 
up of the following three managers:    

  
o System Manager 
o Area Manager 
o Delivery Manager  

 
A System Manager manages reservoir releases that are requested for delivery into the 
area modeled.  An Area Manager determines the allocation of available water resources 
to meet the requests for water from the Delivery Managers.  Last, the Delivery Manager 
distributes the water to individual Land Managers.  
  
Using the data provided, you will learn how to create visual representations of Delivery 
Managers.  You will also become familiar with each Managers' editor and their 
information requirements.   
 
A LAWS project is provided in the LAWS install directory under the subdirectory 
LAWS/Workshop/Exercise 5.  In this exercise, you will gain experience by using a 
simple fictitious area named Deltaville. 
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                         Figure 5.1 - Deltaville Agricultural Region  

 
 
 

Task Description 
 
The goal of this exercise is to become familiar with creating and editing System, Area, 
and Delivery Managers.  You will become familiar with using the Delivery Manager 
Tool to create new Delivery Managers within the Map Schematic.   
 
 
  

Getting Started 
 
   

• Launch LAWS by double-clicking on the LAWS icon on your PC's desktop. 
 
• Select Open Project from the File menu.  
  
• Browse to the LAWS install directory using the File Browser and select the 

LAWS/Workshop/Exercise5/Exercise5.prj file. 
 
• Then click Open.   
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The Exercise 5 project will load into LAWS.  
 

 
             Figure 5.2 - Project Exercise 5 
  

• Open the Sandy River Stream Alignment by right-clicking on the Sandy River 
node label in the Project Tree and selecting Open from the popup menu.   

 

 
  

The Sandy River stream alignment will draw in the current Map Schematic. 
 

• Open and load the "Base" Land Module by right-clicking on the Base node and 
selecting Open from the popup menu. 
   

The Land Managers will appear on the Map Schematic like those pictured below in 
Figure 5.3. 
 

• Open and load the "Basic" Flow Network Module by right-clicking on the Basic 
node and selecting Open from the popup menu.   
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Creating a Water Management Module 
 
The Water Management Module holds the three managers that represent the water 
resource management area.   
 

• Right-click the Water Management node    in the Project Tree and select 
New... from the popup menu.   

 
• The New Water Management dialog appears.  Give the Module the Name 

"Main" and a Description. 
 
• Click OK.   
 
• A new node  with the label "Main" will appear under the Water 

Management Module node.  The Delivery Manager Tool  , will also be 
added to the current Map Schematic.  However, it will not be available for use 
until the System and Area Mangers are created. 

 

 
              Figure 5.3 - Land Managers 
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Creating a System Manager 
 
 

• Right-click on a Main Water Management node and select Edit -> System 
Manger from the context menu.   

 
• The System Manager Editor will appear.  In the System Manager menu select 

New.... 
 
• A New System Manger dialog will appear.   
 
• Give the new System Manager the Name "Base System" and a Description then 

click OK.   
 
• The editor will fill with the new System Manager's information. 

 
 
Editing the System Manager 
 

 
                             Figure 5.4 - System Manager Editor 

 
TIP: Use the Help menu in the editor to learn more about the System Manager Editor 
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Create a Reservoir Account for the System Manager. 
 

• Select the Add Account button on the Reservoir Accounts tab of the System 
Manager Editor dialog. 

 
• The New Reservoir Account dialog will appear.   
 
• Name the Reservoir Account  "Reservoir Account 1". 
 
• Select Farmer Reservoir in the Reservoir dropdown list and click OK. 
 
• Set the % Conservation Storage for the Reservoir1 to 70% and then click OK.  

 

• Save the project changes so far by clicking on the Save All icon  on the main 
toolbar. 

 
 

Creating an Area Manager 
 

• Right-click on a Main Water Management Node and select Edit -> Area 
Manager from the context menu.   

 
• The Area Manager Editor will appear.  In the Area Manager menu select 

New.... 
 
• A New Area Manger dialog will appear.   
 
• Give the new Area Manager the Name "Base Area" and a Description then click 

OK.   
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Editing the Area Manager 
 
 

 
                             Figure 5.5 - Area Manager Editor 

 
TIP: Use the Help menu in the editor to learn more about the Area Manager Editor 
 
Link the Area Manager to the System Manager. 

 
• Select the Add Account button on the Water Accounts tab of the Area 

Manager Editor dialog. 
 
• The New Water Account dialog will appear.   
 
• Give the new Water Account the Name "Base Account" and a Description. 
 
• Select your previously created System Manager in the System Manager 

dropdown list and click OK. 
 
• Set the Max Yearly Volume to 10000 ac-ft. 

 
• Once you are done, click OK to save and close the editor. 

 

• Save the project changes so far by clicking on the Save All icon  on the main 
toolbar. 
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Creating Delivery Managers 
 
Delivery Managers are the one piece of the Water Management Module that is created in 
the Map Schematic.  Delivery Managers are drawn over the Land Managers.  The 
Delivery Managers link the actual Land Managers to the Area Managers.  In our 
example, we will create two.   
 
The idea is to enclose Land Managers in the Delivery Managers.  In our example we are 
enclosing the top 8 Land Managers in one Delivery Manager and the bottom 7 in another 
Delivery Manager.  In Figure 5.7 below, the left screen shot shows the Delivery Mangers 
without displaying the Land Managers.  The right-side shows the Land Managers 
displaying on top of the Delivery Managers. 
 
This exercise is only to get you used to using the tools.  Use Figure 5.7 below as a 
reference on placement, but do not worry about copying it perfectly.   
 

 
                    Figure 5.6- Delivery Managers       
 

• Select the Delivery Manager Tool  on the Map Schematic.  
 

TIP: The Delivery Manager Tool is used exactly like the Land Manager Tool.   
 
• While holding down the Ctrl key, click in the Map Schematic were you would 

like to place the first point.  
 
• Continue creating the outline of the manager's shape by clicking points on the 

map.  
 
• Be sure to encompass each Land Mangers in only one Delivery Manager Area.   
 
• For the final point, release the Ctrl key and click near or on the first point.  
 
• Be sure to create an enclosed area and not overlap the outline on itself.   
 
• A dialog will appear prompting you to give the Manager a Name, Description, 

and assign it the previously created Area Manager.   
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• Click OK.   
 
• The outlined area will be filled in with a transparent color, so you can see the 

Land Managers it encompasses.  Otherwise, it will appear blue.  Create as many 

he color associated with the Area Manger 
assigned to it.  In our case, there is only one Area Manger, so both Delivery 

diting the Delivery Managers

Delivery Managers as you would like. 
 
• Each Delivery Manager will fill with t

Managers will fill with the same color, red. 
 
 

E  
 

 
     Figure 5.7 - Delivery Manager Editor 
 

P: Use the H e Delivery Manager Editor 

in the Map Schematic. 

 Editor dialog will appear. 

 to Junction 3 and the Return 
Location to Junction 5. 

TI elp menu in the editor to learn more about th
 

• Be sure to select the Selection Tool and then double-click on a Delivery Manger 

 
• The Delivery Manager
 
• On the Connectivity tab set the Diversion Location
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 Select the other Delivery Manager you created in the Drainage Available to 

• On the Physical Parameters tab enter the following values: 

o Delivery Canal 
osphere - 5% 

 

o Drain 
ses to Atmosphere - 10% 

 
 On the Management Parameters tab enter the following information: 

o Groundwater Min Use - 0% 
 

 
  o  orry about filling the information for the next Delivery Manager.  The 

 Once you are done filling in the information, click OK to save and close the 

•
Other Delivery Managers and enter the value 20% in the Percent column. 

 

 

 Losses to Atm
 Losses to Groundwater - 10%

 

 Los
 Losses to Groundwater - 5% 

•
 

o Groundwater Max Use - 80%
o Drain Water Re-use - 10% 

• Do n t w
information will be filled out for you in the next exercise.  

 
•

dialog.   
 
 
Saving the Project and Exiting LAWS 
 

• Save the Project by selecting Save Project in the File menu.  

 Exit LAWS from the File menu. 
 
•
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Exercise 6 – Alternatives, Computing, and 
Viewing Results 
 

Introduction 
 
In Exercise 6 all the previous exercises come together to create a computable Alternative.  
Each Module created provides the choices and alternatives for modeling the system.  
After creating and computing the alternative, results can be viewed.  There are four 
different ways to view results in LAWS: 

 
o Plots 
o Summaries 
o Reports 
o Animation 

  
A LAWS project is provided in the LAWS install directory under the subdirectory 
LAWS/Workshop/Exercise6.  In this exercise, you will gain experience by using a simple 
fictitious area named Deltaville. 

 

 
                              Figure 6.1 - Deltaville Agricultural Region  
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Task Description 
 
The goal of this exercise is to become familiar with creating, editing, and computing an 
Alternative.  You will also become familiar with interacting with the four types of results: 
plots, reports, summaries, and animation.  
 
 
  

Getting Started 
 
   

• Launch LAWS by double-clicking on the LAWS Icon on your PC's desktop. 
 
• Select Open Project from the File menu.  
  
• Browse to the LAWS install directory using the File Browser and select 

LAWS/Workshop/Exercise6/Exercise6.prj file. 
 
• Then click Open.   

 
 
The Exercise 6 project will load into LAWS.  
 

 
              Figure 6.2 - Project Exercise 6 
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Creating and Editing an Alternative 
 

• Right-click the Alternative node  in the Project Tree and select New... from the 
popup menu.  The New Alternative dialog will appear.   

 
• Give the Alternative the Name "BaseAlt" and a Description.  Then click OK.  

 
• The Alternative Editor dialog will appear with the new Alternative selected for 

editing.  
 

 
                         Figure 6.3 - Alternative Editor 

 
Selecting Modules: 
 

• On the Module tab of the Alternative Editor, select the Modules you would like 
the Alternative to use.  In this example of LAWS, each module has only one 
choice in their dropdown lists.  Select each choice for the corresponding module.  
If you have any droughts, see Error! Reference source not found. above. 

 
Run Controls tab: 
 

• The computation period is specified on this tab.  For the Start Date enter 
"31Oct2000".  For the End Date enter "31Oct2002".  

 
• Click the box next to Write Land Manager ASCII Output File. 
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Input Time Series tab: 
 

 
Figure 6.4 - DSS Pathname Selection 
 
On the Input Time Series tab, DSS files are assigned to the Met Stations and the 
Reservoir.  Using the following table, assign the corresponding Time Series data to the 
Met Stations and Reservoir. 
 
Location Variable Dss File Pathname 
Met Station 1 ETO cimis.dss DELTAVILLE/CENTRAL/ETO 
Met Station 1 Precip cimis.dss DELTAVILLE/CENTRAL/PRECIP 
Met Station 2 ETO cimis.dss DELTAVILLE/LOWER/ETO 
Met Station 2 Precip cimis.dss DELTAVILLE/LOWER/ PRECIP 
Met Station 3 ETO cimis.dss DELTAVILLE/UPPER/ETO 
Met Station 3 Precip cimis.dss DELTAVILLE/UPPER/ PRECIP 
Reservoir 1 NetInflow cdec.dss ORO/RESERVOIR INFLOW           

 
• Click on and highlight a row in the Input Time Series table.  This will be the first 

row you will set a DSS pathname for.    
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• Select the Browse DSS Paths button. 
 
• A Select Time Series Path dialog displays*. 
 
• In the browser, select File -> Open.  Use the file browser to find the location of 

the DSS files on the provided in the Workshop directory.  The two files you will 
use are in the LAWS install directory under the following subdirectory:  
LAWS/Workshop/Exercise6/DataSheets 

 
• Click OK. 
 
• The DSS file will fill the Select Time Series Path dialog with its available dss 

paths.  
  
• In the Select Time Series Path dialog, click and highlight the path you would 

like to assign to the highlighted row back on the Alternative Editor.  
 
 
• Click the Set Pathname button.  This will assign the DSS pathname to the 

selected row back on the Alternative Editor.  Once a path is chosen, it will 
display in the Alternative Editor's Time Series table in the row it was assigned 
to. 

 
• Now assign a pathname to the next row on the Alternative Editor.  Click on and 

highlight the next row on the table.  Go back to the Select Time Series Path 
dialog and choose the dss pathname.  Repeat the process for the remaining rows.  

• When you are done, close the Select Time Series Path dialog using the  
button in the upper right-hand side of the dialog. 

 
• Click OK to save the changes and close the Alternative Editor. 
 
• To display all the map elements for the new Alternative, click on the Alternative's 

node.  Then, while holding down the mouse key, drag the Alternative node to the 
empty Map Schematic. 

 
• Save the Alternative's data to the project files.  Click on the  Save All icon on 

the main menu bar. 
 

*A full version of HecDssVue is available through the Tools menu on the main menu bar.  
For more information on HecDssVue, see the online help section Interface, Additional 
Tools. 
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Computing the Alternative 
 
There are two ways to start the compute running for an Alternative.   
 

• Select Simulation -> Compute Alternative from the main menu bar or... 
 

• Right-click the Alternative's node and select Compute from the popup menu. 
 
 
Once the Alternative starts computing, a compute progress bar will display.  A compute 
message tab, labeled with the Alternative's name, will be added to the Messages Pane 
area on the bottom of the LAWS screen. 
 
 

Viewing Plot Results 
 
Once the Alternative has successfully computed, you can access the resulting plots.  If 
you are having trouble with the compute, you can go ahead and open the first completed 
Exercise6 project provided under the LAWS/Workshop/Completed directory, named 
Complete.prj. 

 
Plots are accessed through right-click context menus on specific graphics on the Map 
Schematic.   
 

• Select the Pointer Tool  in the Map Schematic. 
 
• Right-click on Reservoir1 and select Plot Flow and Storage from the popup 

menu. 
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                                 Figure 6. 5 - Plot Dialog 

 
• The Reservoir Flow and Storage Plot dialog will appear.  Play around with the 

plot.  Use the Zoom Tool to get a closer look at the data.  Place the mouse over 
the plot line.  Explore the menu options.  When you're done, close the Plot 
window. 

 
• Right-click on other graphics in the map and locate more plots. 
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Viewing Summary Results 
 

 
                        Figure 6.6 - Summary Dialog 
 
Summaries are available through the Alternative node's right-click popup menu.  The 
summaries display the total monthly values for a variety of variables computed for the 
time period.   

 
• View a summary by selecting View Water Balance Summary from the 

Alternative node's popup menu.  
 
TIP:  You can also use the Results menu to access the summaries. 
 
TIP:  Use the scrollbars located on the right-side and bottom of the summary dialog 
to view more data.  

 
 
 
Create a Second Alternative 
 
Before viewing the animation results of the Alternative, let's create a new Alternative to 
compare the results with.  We will use the Alternative we just created, but change some 
of its data. 
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Make a new Crop Schedule to use in the new Alternative.   
 
• Double-click on the Crop Schedule node.  The Crop Schedule Editor will 

appear.   
 
• Select Crop Schedule -> New from the menu in the editor. 
 
• In the New dialog Name the new Crop Schedule "Rotation 3". 
 
• Set the new schedule to only plant Wheat with the starting year of 1999. 
  
• When you are done entering the information on Wheat, click OK  to save and 

close the editor. 
 
Now create a new Cropping Plan from the original, "Simple Plan", and assign your new 
Crop Schedule to a few Land Managers. 
 

• Right-click on the "Simple Plan" Cropping Plan and select Save As from the 
popup menu.   

 
• In the Save Cropping Plan As dialog, Name the new Cropping Plan, "Simple 

Plan2" and then click OK. 
 
The new Cropping Plan will appear as a node under the Cropping Plan section of the 
Project Tree. 
 

• Open the "Simple Plan2" editor by double-clicking on the node. 
 

• In the Cropping Plan Editor, change a few of the Land Managers to use the new 
"Rotation 3" Crop Schedule.  Then click OK to save and close the editor. 

 
Create the new Alternative and assign it the new Cropping Plan. 
 

• Right-click on BaseAlt and select Save As from the popup menu. 
 
• In the Save Alternative As dialog, Name the new Alternative "BaseAlt2", then 

click OK. 
 
The new Alternative will appear as a "BaseAlt2" node under the Alternative node in 
the Project Tree. 

 
• Right-click on the BaseAlt2 Alternative's node and select Edit from the popup 

menu.  The Alternative Editor will appear filled with the BaseAlt2's information. 
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• On the Modules tab of the Alternative Editor, select the new "Simple Plan2" 
Cropping Plan from the Cropping Plan dropdown list.  Then click OK to save 
and close the editor. 

 
• Save all the changes you made to the project file.  Click on the  Save All icon 

on the main menu bar. 
 
 
 

Viewing Animation Results 
 
Once the second Alternative is computed successfully, its results can be animated along 
with the original Alternative's results.  The animations are defined by color variations of 
the Land Modules, which change with each time step.  
 
If you are having trouble with computing BaseAlt2, you can open the next completed 
Exercise6 project containing both Alternatives.  The project is provided under the LAWS 
install directory under the following subdirectory: 
LAWS/Workshop/Completed2/Complete2.prj. 
 
Open both Alternatives in separate Map Schematic windows.  The first Alternative, 
BaseAlt, should already be displayed in a Map Schematic window.  However, if it is not, 
double-click on the alternative's node in the Project Tree. 
 

• Double-click on the BaseAlt2 node. 
 
A Select Map dialog should appear. 
 

• In the Select Map dialog, click the New Map Window radio button and then 
click OK. 

 
• The BaseAlt2 Alternative will appear in a new Map Schematic window. 

 
Display the two alternatives side-by-side. 
 

• Select Window -> Tile in the main LAWS menu bar.   
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                   Figure 6.7 - Tile Map Panels 
  
To Animating the Results: 

  
• Select the Land Module Display Properties Tool  on the main LAWS 

Toolbar.  The Land Module Display Properties dialog will display. 
 

 
                          Figure 6.8- Land Module Display Properties Dialog 

 
• The model properties available for animation are listed on the left side of the 

Land Module Display Properties dialog.   
 
• Select the Crop Types property and click OK. 
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• Notice a color legend appears in the Map Schematic.  The legend indicates a color 
for each Crop Type.  As the results are animated, the Land Managers will change 
color according to the Crop Type's assigned to then at the time step. 

 

 
                                 Figure 6.9 - Legend 

 
• Select the next Alternative's Map Schematic window and add a Legend to it by 

repeating the steps above. 
 
 
Animate both windows at once. 
 

• Click on the Animation Tool  on the main toolbar. 
 
• The Animation Results dialog appears. 

 

 
Figure 6.10 - Animation Controls 

 
• The dialog functions similar to a VCR.  There is a play button, fast forward 

button, etc. 
 
• Click on the play  button.   
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• To speed up the play, click the fast-forward  button. 
 

TIP: You can also speed up the play be increasing the Play Delays in the Set Delays 
dialog.  To access this dialog select Configure -> Delays in the Animation Results 
dialog. 
 
As the slider moves along in time, the color variations on the Land Managers will change 
according to there output values at the time step. 
 

• Continue exploring different variables in the Land Module Display Properties 
dialog.  

 
TIP: The only variables that show color variation when played are those with the gear 
icon  next to them.  
 
 

Saving the Project and Exiting LAWS 
 

• Save the Project by selecting Save Project in the File menu.  
 
• Exit LAWS from the File menu. 
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